Jump to content


- - - - -

Opening NC file


  • Please log in to reply
4 replies to this topic

#1 Mick

Mick

    Poison Ivy

  • Members
  • PipPipPip
  • 1,651 posts
  • Location:Kicked in the corner

Posted 10 April 2012 - 07:48 PM

Hi there,

I have an end user opening an NC file in Easytalk (remember that? :)). Anyway, the file looks as if it is missing the carriage returns, so it is one long line of code.

However, when I open the same file in Cimco Edit, or in Notepad or Wordpad, the lines look normal.

Nothing has changed in Easytalk, and he hasn't had this problem before. I'm just curious if anyone knows how to correct this? The settings all appear correct in Easytalk. Perhaps his NC file has somehow got reformatted?

#2 Guest_SAIPEM_*

Guest_SAIPEM_*
  • Guests

Posted 11 April 2012 - 04:06 AM

The problem is on his end.
It's probably not recognizing the CR-LF as the End-of-Block.

The fact that you are even trying to support a DOS era comm program is crazy.
http://www.cncinnov.com/easytalk

#3 Mick

Mick

    Poison Ivy

  • Members
  • PipPipPip
  • 1,651 posts
  • Location:Kicked in the corner

Posted 11 April 2012 - 03:16 PM

View PostSAIPEM, on 11 April 2012 - 04:06 AM, said:

The problem is on his end.
It's probably not recognizing the CR-LF as the End-of-Block.

The fact that you are even trying to support a DOS era comm program is crazy.
http://www.cncinnov.com/easytalk

I'm not supporting it :P

And if you saw the equipement being used, then a DOS era comm program is a big step up.

#4 DavidJackson

DavidJackson

    Member

  • Members
  • PipPip
  • 68 posts

Posted 11 April 2012 - 03:46 PM

i was curious about this as notepad wont give a new line without a complete cr-lf, if it just has one or the other it will show one
long line, but cimco is happy with just a cr or a lf by themselves.

with that in mind and saying that it displays correctly for you in notepad, as per saipem, you would have to guess the 10+13 have
gone missing from the easytalk config, or at the stretch the file was opened and saved on a mac/*nix machine,
which if you tried really hard could change the crlf to either just cr or lf?)

#5 rocheey1

rocheey1

    Advanced Member

  • Members
  • PipPipPip
  • 314 posts
  • Location:Massachusetts

Posted 13 April 2012 - 08:31 AM

View PostDavidJackson, on 11 April 2012 - 03:46 PM, said:

i was curious about this as notepad wont give a new line without a complete cr-lf, if it just has one or the other it will show one
long line, but cimco is happy with just a cr or a lf by themselves.

with that in mind and saying that it displays correctly for you in notepad, as per saipem, you would have to guess the 10+13 have
gone missing from the easytalk config, or at the stretch the file was opened and saved on a mac/*nix machine,
which if you tried really hard could change the crlf to either just cr or lf?)

or just drag the file into Wordpad, and save. The CR-LF pairs will then be there.