Jump to content

Welcome to eMastercam.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

Warning-not all boundaries are closed....

- - - - -

  • Please log in to reply
10 replies to this topic

#1
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
XMR1 Mill3

I have a couple of 2D arches that look like "C" nested next to each other about 2 inches apart, one a little larger than the other and connected on the ends to form a pocket that looks like a big "C" outline. When I try to pocket this out, I can't get the boundaries to chain all the way around. If I chain it by selecting each single part, then I get a message that says "Warning- not all boundaries are closed. Select Open Pockets or close chains." Problem is, these are drawn endpoint to endpoint and so I don't see how the chain is not closed. If I select all the entities and tell Mastercam to join them, then it says "Some divided entities, which are not connected but which are based off the same original entity have been found. Do you want to close the gap and join them?" If I say "Yes", it draws a line all the way across the ends of the "C" shapes which is nuts. I tried to analize the the chain and it says all is fine. I'm guessing there must be gaps but I can't figure out how to find them and/or fix them.

Thanks- PBPaul

#2
Thad

Thad

    Highly Advanced Member since May 2002

  • Members
  • PipPipPip
  • 11,138 posts
  • Location:Michigan
Are you sure they all reside it the same plane? You could try squashing it or give the iso view a quick look.

If you analyze chain, does the chain start where you click it? Does is chain all the way around? Don't use partial chain when trying this. If it doesn't start where you click, try zooming in (way in) to the start or end point and see if there's a gap. If you don't see one, move your mouse over the geometry and see if the geometry flickers. If so, you probably have entities on top of one another. This will cause a branch point.

You could also make sure you're in the right construction plane.

Thad

#3
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
Thad:
If I analyze, it starts where I click but will not chain all the way around. I cannot see a gap, however.
I think I figured out that the problem might be that this was originally drawn in Rhino. If I erase some of the lines and draw them back in exactly the same place in Mastercam, then it chains correctly. I can draw something in Rhino like this and connect ends together using lines that snap to endpoints and so forth so there is no question that there should be no gaps, and one day it works fine and the next, it won't. It does not seem to matter if the Rhino is saved as an IGS or if I use Mcam to open it directly. Either way, there are gaps happening somehow. I hadn't thought of squashing so I'll try that.
Thanks- PBPaul

#4
robk

robk

    Advanced Member

  • Members
  • PipPipPip
  • 3,687 posts
  • Location:Berlin, Connecticut
Go into your chain options and uncheck all your masking options.

#5
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
Thanks Rob but that had no effect.

#6
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
Also, xform squash is apparently not in X. I tried xform join but that didn't solve it either.

PBPaul

#7
robk

robk

    Advanced Member

  • Members
  • PipPipPip
  • 3,687 posts
  • Location:Berlin, Connecticut
PBPaul squash is under XFORM Project in X.

#8
Chris Flint Two Ft Pty Ltd

Chris Flint Two Ft Pty Ltd

    Member

  • Members
  • PipPip
  • 151 posts
Try deleting the chains one by one by one
and see the result, after a repaint if you end up with bits left behind, there is your problem.
Sometimes you have to zoom in about a million times to find the problem, I find it quicker to delete and redraw to endpoints.

#9
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
I found Squash but that didn't fix it. I finally just deleted the entities and drew them again in Mastercam, as Chris suggested, and they worked. I can draw two ellipses in Rhino and draw legs off the ends and connect them and bring it to Mastercam and it chains fine. If I do the same with Half Round arches, Mastercam trips up the chaining. Just for the heck of it, I tried grabbing one of the arches and one of the lines (in Mastercam) and just simply joining them. Not a good idea.....some of the entities simply disappear. On a positive note, I have noticed in the MR1 release that some of the Rhino issues I brought up, such as missing Layers/Levels, have been fixed. On the other hand MR1 Backplot gives me grief on the simplist things whether they are drawn in Mastercam or Rhino or Autocad. I guess that needs to be another thread.

PBPaul

#10
Hardmill

Hardmill

    Anti-Moderator

  • Members
  • PipPipPip
  • 17,334 posts
  • Location:Gardnerville, Nv
There has to have been some overlapping entities,
any chance you got the original file to share. biggrin.gif


PEACE biggrin.gif

#11
PBpaul

PBpaul

    Member

  • Members
  • PipPip
  • 233 posts
Thanks, Hardmill. If I can remember how, I'll send it up to the FTP. Bottom line, I'm almost certain it has to do with bringing stuff in from Rhino.

PBPaul