Jump to content

Welcome to eMastercam.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

X+ Setup Sheet and Tool List - 3rd party Add-on

- - - - -

  • Please log in to reply
443 replies to this topic

#221
Brian @ PM Mold

Brian @ PM Mold

    Wannabe Programmer

  • Members
  • PipPipPip
  • 644 posts
  • Location:Schaumburg, IL
Thanks Gunther.

1 more question - is it possible to specify the path where the HTML file is saved?

#222
Metal_Eater

Metal_Eater

    Member

  • Members
  • PipPip
  • 57 posts
Hello Gunther,

The Z-Min dimension output for is incorrect for 3d surface tool paths. Mcam X6MU1. Could you please look into this?

#223
Günther Massimo - GMCCS

Günther Massimo - GMCCS

    Advanced Member

  • Resellers
  • PipPipPip
  • 441 posts

Thanks Gunther.

1 more question - is it possible to specify the path where the HTML file is saved?


The only way is:
Save as... from your Browser.

#224
Günther Massimo - GMCCS

Günther Massimo - GMCCS

    Advanced Member

  • Resellers
  • PipPipPip
  • 441 posts

Hello Gunther,

The Z-Min dimension output for is incorrect for 3d surface tool paths. Mcam X6MU1. Could you please look into this?


Can you send me an example please?

It looks OK to me.

#225
Brian @ PM Mold

Brian @ PM Mold

    Wannabe Programmer

  • Members
  • PipPipPip
  • 644 posts
  • Location:Schaumburg, IL

The only way is:Save as... from your Browser.


Thanks Gunther!

#226
mario

mario

    Member

  • Members
  • PipPip
  • 298 posts
Where is rename nci for X6

Günther Massimo I am dummy for modified .dll.....

let me know with more information to make easy

excuse my english !!

Merci Mario

Posted Image

#227
peon

peon

    Advanced Member

  • Members
  • PipPipPip
  • 1,034 posts
Good morning Gunther. I noticed the cycle time for the pencil path is inaccurate. The pencil path I just toolpathed backplots at 25 minutes and the setup sheet is displaying 4 hours and 40 minutes. I remember seeing this a couple years ago and you found a fix at that time. Thanks for a great setup sheet!! :D

#228
Bill

Bill

    Member

  • Members
  • PipPip
  • 257 posts
  • Location:Scottsdale AZ

New upload.
Chaining dialog added.



I downloaded the latest upload. I still don't see the chaining dialog icon.

#229
Günther Massimo - GMCCS

Günther Massimo - GMCCS

    Advanced Member

  • Resellers
  • PipPipPip
  • 441 posts

Hello Gunther,

The Z-Min dimension output for is incorrect for 3d surface tool paths. Mcam X6MU1. Could you please look into this?


fixed.
  • 35K chipper likes this

#230
volsfan

volsfan

    Member

  • Members
  • PipPip
  • 15 posts
All my tool Dia and depths only have 2 places decimals, Where and how can I change this. I am still using X+ for mastercam x3 and I create my tool list out to excel. I have looked but can't seem to find where I can edit this.

Thanks,

Brian

#231
volsfan

volsfan

    Member

  • Members
  • PipPip
  • 15 posts
I found how to change my decimals to 3 places however how can I change the name of the columns? I want to rename them to instead of tl_nr to Tool # and so on with other columns. Please help.

Thanks,
Brian

#232
GV

GV

    Newbie

  • Members
  • Pip
  • 7 posts

It's in the clipboard.
You can paste it in almost any application.
Do you think the "save as file" option is necessary?


Günther,
For me the "save as file" option was great. I was taking screenshots during verify, so the operator was able to have a quick reference how the part should look at different stages.
Thanks for all the great work!

#233
John Hill @ Poplar Hill Machine

John Hill @ Poplar Hill Machine

    Member

  • Members
  • PipPip
  • 126 posts
  • Location:Conway, MA
Hey Günther,

Installed X+ for X6 and now have the layout as I like it. It appears that the number of decimal places is no longer taken from the systems Regional & Language settings. Some values are truncated to 1 place (no trailing zeros) and others go to 4 places.

How do I control the number of decimal places?

Also, I really miss the scrollable tool list preview that showed with the X5 version! I used it on every job to preview Z Min vs Extension & Flute Length without having to launch a browser. It was great for quickly listing tools used on a specific B rotation for horizontals too.

Any chance of bringing it back?

In the X5 version, the css code contained a way to alternate the background color of the tool rows for clarity. I can't get this to work with the X6 version...any suggestions?

And finally, would it be possible to add the ability to rename the tool list headers?

Thank you for creating & supporting the X+ Setup Sheet...its indispensable and greatly appreciated!

John

#234
Brian @ PM Mold

Brian @ PM Mold

    Wannabe Programmer

  • Members
  • PipPipPip
  • 644 posts
  • Location:Schaumburg, IL
Any way to get the Tplane Name to output on drilling cycles?

#235
volsfan

volsfan

    Member

  • Members
  • PipPip
  • 15 posts

Like this?
I use a resource editor (reshacker) to change. I didn't see another way to do it.:thumbsup:

Posted Image

what DLL do you edit to do this? I checked them all and could not find it.

#236
Josh K.

Josh K.

    Advanced Member

  • Members
  • PipPipPip
  • 1,003 posts

what DLL do you edit to do this? I checked them all and could not find it.


The lang.dll

You'll probably have to save it to the desktop and then move the old, copy the new to the chooks\X+ folder.

It's string table 5 that your looking for.

#237
volsfan

volsfan

    Member

  • Members
  • PipPip
  • 15 posts

The lang.dll

You'll probably have to save it to the desktop and then move the old, copy the new to the chooks\X+ folder.

It's string table 5 that your looking for.



Thanks Josh however when I try to view string 5 I get an error saying its a non-standard resource layout and has probably been compressed with an "EXE" compressor. I am using Resource Hacker to view it or try to I should say. Am I missing something??

Thanks,
Brian

#238
volsfan

volsfan

    Member

  • Members
  • PipPip
  • 15 posts
I also tried xnresource editor and got an access violation with that string

#239
Josh K.

Josh K.

    Advanced Member

  • Members
  • PipPipPip
  • 1,003 posts
Makes sure you copy it before trying to edit. I haven't had any issues. Maybe try running Resource Hacker in Admin mode?

Josh-

#240
Josh K.

Josh K.

    Advanced Member

  • Members
  • PipPipPip
  • 1,003 posts
Her'es a cop of my lang.dll

I changed quite a bit in mine.

Josh-

https://docs.google....MElsbXVIQ0hOdlE