Jump to content

Welcome to eMastercam.com
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

Engraving

- - - - -

  • Please log in to reply
13 replies to this topic

#1
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca
I haven't used engraving in a few months, but I have used it with this release. I'm trying to engrave a part number. Using the actual engraving toolpath since it's heavy text. It's simple 2D lettering. I get the error after I click the green check after chaining. I tried it on the most simple squarebox and it still errors. WTH? Isnt the engraving TP included with X5? It couldn't have expired could it. Maint. is up to date.

#2
Manuel0822

Manuel0822

    Member

  • Members
  • PipPip
  • 121 posts
I don't know about this issue on MC but as long as it's not rotary around a cylinder you may want to check this out:

My link

Way simpler than MCX

#3
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca
Nope, just a flat plain jane number. Standard pocket works, but now I'm obsessed with why this isnt working. Oh, and link is blocked here.

#4
gcode

gcode

    Serenity

  • Moderators
  • 20,806 posts
  • Location:Jurupa Valley, California
I think there is a bug with X5 Engrave ....it won't launch on x64 systems

#5
Manuel0822

Manuel0822

    Member

  • Members
  • PipPip
  • 121 posts
Just tried it here on X6 x64 and won't run either.

#6
Oscar R.

Oscar R.

    Advanced Member

  • Members
  • PipPipPip
  • 345 posts
  • Location:SoCal , USA
I just tried it on my X5 x64 system and it works. I don't use it very often but that's only by chioce. I find that running a contour path with comp turned off is just simpler, and I'm not restricted to using only engraving tools.
We usually use a .020 ball emill to do our engraving here. Works out pretty good for the most part.

#7
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca
Dang bug. Yea I always 2D comp off with an engraving tool, but this situation has fat lettering/logo and they want the entire letter to be "pocketed". Regular pocket works, but I liked using Engrave for this situation

#8
Oscar R.

Oscar R.

    Advanced Member

  • Members
  • PipPipPip
  • 345 posts
  • Location:SoCal , USA
Works good here.

Am I missing something here? Is your toolpath actually loading but note doing anything after chaining? You sure you're using actaul lettering and not not just note text?

#9
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca
Yup it's 2 box letters, .75 tall. Closed chain. I chain them, then click the green check, ding "Cannot create operation"

#10
NOTW Programmer

NOTW Programmer

    Advanced Member

  • Members
  • PipPipPip
  • 435 posts
Works here also, I do always use the controur with comp off; I get to ramp entry.

#11
Pilot Plant Supervisor

Pilot Plant Supervisor

    Member

  • Members
  • PipPip
  • 228 posts
  • Location:Albany, Oregon
I've never used it, but just tried it in X5 MU1 and it worked great. My computer is 64 bit, but isn't X5 32 bit only? I used create-letters, MCX block font, window chain, and checked the rough box in the parameters. No problems on my end.

#12
ajmer

ajmer

    Advanced Member

  • In-House Solutions
  • PipPipPip
  • 310 posts
try running a chook
does it go to the correct directory based on the version that you are running
eg. C:\PROGRAM FILES (X86)\MCAMX5\CHOOKS\ if you are usign X5

if it does not
settings-->configuration-->files-->custom addin/dll and change to the path above.

save and try engraving again

#13
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca

<br>try running a chook<br>does it go to the correct directory based on the version that you are running<br>eg.&nbsp;&nbsp; C:\PROGRAM FILES (X86)\MCAMX5\CHOOKS\&nbsp;&nbsp;&nbsp;&nbsp;if you are usign X5<br><br>if it does not <br>settings--&gt;configuration--&gt;files--&gt;custom addin/dll and change to the path above.[<br><br>save and try engraving again<br>

<br><br><br>BINGO!<br><br>

#14
Mic6

Mic6

    Advanced Member

  • Members
  • PipPipPip
  • 3,259 posts
  • Location:Sunnyvale, Ca

try running a chook
does it go to the correct directory based on the version that you are running
eg. C:\PROGRAM FILES (X86)\MCAMX5\CHOOKS\ if you are usign X5

if it does not
settings-->configuration-->files-->custom addin/dll and change to the path above.

save and try engraving again


Bing! Thanks Amjer. It wasnt seeing the (X86) folder. Toolpath secured
:unworthy: