Sign in to follow this  
Leon82

Is it possible to get a comma to post after each block number?

Recommended Posts

Try changing your format for the N to N,

fmt  "N" 21 n$          #Sequence number

to

fmt  "N," 21 n$          #Sequence number

  • Like 2

Share this post


Link to post
Share on other sites
Just now, JParis said:

Try changing your format for the N to N,

fmt  "N" 21 n$          #Sequence number

to

fmt  "N," 21 n$          #Sequence number

Close, but not quite.

fmt  "N" 4  n$ ","

 

  • Like 3

Share this post


Link to post
Share on other sites
12 minutes ago, Zaffin said:

Close, but not quite.

fmt  "N" 4  n$ ","

 

Yup...that's what I get for working on the fly  :)

Share this post


Link to post
Share on other sites

Yes, as Zaffin pointed out, the Format Assignment function inside MP-based Posts was enhanced to allow you to output both a "Prefix String", and a "Suffix String". So you can output "string characters" before or after the numeric value being output.

I like to do this for outputting "Feed Variables". I like to output my Feeds as " F[#501] ", where the "F" value is called as a Permanent Common Variable.

Inside Mastercam, I enter "501." for the Feed, "502." for the Plunge rate, and "503." for the Retract Rate.

I have logic built into the Post to detect "Feedrates above 499", which will then "swap format assignments" on-the-fly. I also add some logic to check MR4, MR5, and MR6. I use these three MR values to pass along the actual "Feedrate value" which I want assigned to each variable.

At the start of a new Operation (Tool Change), I get something like this:

#501 = 130.
#502 = 200.
#503 = 500.

Which gives me a single place where I can change any of the Feed values (cut, plunge, or retract), and it will now read that variable value as part of the NC Code.

M01
N1(SEQUENCE #1.)
(TOOL# 5 - 0.1875 FLAT ENDMILL -  DIA. - .1875)
(MAX - Z-1.0519)
G0 G17 G40 G80
G00 G90 G53 Z0.
#501=130.
#502=200.
#503=500.
T5 M06
(FLATS)
G00 G17 G90 G54 X-2.4243 Y-1.1527 S9876 M03
G43 H5 Z2. M83
Z-.26
G01 Z-.31 F[#502]
X-2.425 Y-1.1525 Z-.3152
X-2.4269 Y-1.1519 Z-.32
X-2.4299 Y-1.1509 Z-.3241
X-2.4338 Y-1.1497 Z-.3273
X-2.4384 Y-1.1482 Z-.3293
X-2.4434 Y-1.1466 Z-.33
G02 X-2.4748 Y-1.134 Z-.3311 I.0697 J.218 F[#501]
X-2.5078 Y-1.1098 Z-.3324 I.0661 J.125
G03 X-2.537 Y-1.1108 Z-.3332 I-.0141 J-.0143
G01 X-2.5565 Y-1.1317 Z-.3333
G03 X-2.5563 Y-1.1582 I.0124 J-.0131
G01 X-2.5432 Y-1.1724
X-2.5263 Y-1.1907 Z-.3341
X-2.3937 Y-1.2583 Z-.3389
X-2.361 Y-1.2679 Z-.34

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I had to delete the string n$ from the tool change line because I was getting 2 line numbers, one after the other.

Is there a different setting that outputs an N number on the tool change?

 

I have it set to output block numbers on all lines in the control def

Increment 1, start 1

 

 

 

Share this post


Link to post
Share on other sites

Hi Leon, I am not completely sure what sort of output you are looking for but if you are using an MPMASTER style post, I would point you towards tseqno in the general output settings at the top of the post.

tseqno      : 0     #Output sequence number at toolchanges when omitseq = yes
                    #0=off, 1=seq numbers match toolchange number, 2=seq numbers match tool number

  • Like 1

Share this post


Link to post
Share on other sites

Ok I'll look at it.

 

It is a generic fanuc post, it's been here for at least 10 years.

 

I only see a seq reference for knot sequence numbers CD var and it say no as I checked it to output them

Share this post


Link to post
Share on other sites

The last CNC software update to it was in 2005.

But what I am experimenting on is a manual entry test for camplete.

It uses what it calls a custom gcode label for manual entry.

 

So the format is

ME1, m00

ME2, (comment)

 

So instead of a sub program for probing or a dovetail op on the table wings it would output directly into the program via manual entry text file..

 

Camplete won't simulate it, but neither will a sub program.

 

 

 

 

Share this post


Link to post
Share on other sites
On 1/9/2020 at 2:41 PM, Alex Dales said:

Hi Leon, I am not completely sure what sort of output you are looking for but if you are using an MPMASTER style post, I would point you towards tseqno in the general output settings at the top of the post.

tseqno      : 0     #Output sequence number at toolchanges when omitseq = yes
                    #0=off, 1=seq numbers match toolchange number, 2=seq numbers match tool number

I finally got around to looking at this again as it only happened with a second tool change. I left a line without the e$ in the tool change post block so it was double posting the line number. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us