Sign in to follow this  
c++

DMS Router Post Issue : Feed from helix bore on final pass outputs wrong value

Recommended Posts

Hi,

we are having an issue with our post processor where the helix bore feed reduction on the final pass if not set to 100% is outputting very low values that were not defined. For example a helix bore at 420 inches per minute (standard feedrate) :D with a 70% reduction w ill output 7.5 inches per minute or in the case today f0. I  created an escalation to raise the issue with our reseller, however I would like to know if this is specifically a post issue or a mastercam specific issue.

Share this post


Link to post
Share on other sites

Have you looked at the NCI to determine if the problem is upstream? 

Do you have the Post documentation?

Share this post


Link to post
Share on other sites
37 minutes ago, Zaffin said:

Have you looked at the NCI to determine if the problem is upstream? 

No, I do not know how to do that. :/ I am not sure what you mean by upstream. 

37 minutes ago, Zaffin said:

Do you have the Post documentation?

I don't have the Post docs I will request them.

Share this post


Link to post
Share on other sites

To generate the ASCII NCI, enable the check box shown below in the Post processing dialog

image.png.27566d738ba6fe32ec0b563166731f7b.png

In my example part, the ASCII NCI looks like this;

image.png.97118188bbd5735d76da7f2b8cdc13f4.png

I've highlighted the feed rate values for clarity;

  • -2 = Rapid move
  • -1 = Feed rate has not changed
  • Any positive value = feed rate in UPM

The first thing you should do is make sure the reduced feed rate is being output in the NCI.

  • Like 1

Share this post


Link to post
Share on other sites
28 minutes ago, Zaffin said:

To generate the ASCII NCI, enable the check box shown below in the Post processing dialog

image.png.27566d738ba6fe32ec0b563166731f7b.png

In my example part, the ASCII NCI looks like this;

image.png.97118188bbd5735d76da7f2b8cdc13f4.png

I've highlighted the feed rate values for clarity;

  • -2 = Rapid move
  • -1 = Feed rate has not changed
  • Any positive value = feed rate in UPM

The first thing you should do is make sure the reduced feed rate is being output in the NCI.

Thank you, as always you are a life saver. Happy holidays ,sir.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us