Sign in to follow this  
Temores2790

Comments not posting

Recommended Posts

I need help with my post because is no posting the comments in tools or in the manual entry it doesn't output the comments or the codes and I have already the option to get the comments

tool_info    : 3    #Output tooltable information?
                     #0 = Off - Do not output any tool comments or tooltable
                     #1 = Tool comments only
                     #2 = Tooltable in header - no tool comments at T/C
                     #3 = Tooltable in header - with tool comments at T/C

 

pstrtool        #Comment for tool
      if strtool$ <> sblank,
        [
        strtool$ = ucase(strtool$)
        *strtool$
        ]
        
        
  pcomment$       #Comment from manual entry (must call pcomment2)
      pcomment2 #Required if doing boolean 'if' logic testing!

pcomment2       #Output Comment from manual entry
      scomm$ = ucase (scomm$)
      if gcode$ = 1005, sopen_prn, scomm$, sclose_prn, e$  #Manual entry - as comment
      if gcode$ = 1006, scomm$, e$                         #Manual entry - as code
      if gcode$ = 1007, sopen_prn, scomm$, sclose_prn      #Manual entry - as comment with move NO e$
      if gcode$ = 1026, scomm$                             #Manual entry - as code with move NO e$
      if gcode$ = 1008, sopen_prn, scomm$, sclose_prn, e$  #Operation comment
      if gcode$ = 1051, sopen_prn, scomm$, sclose_prn, e$  #Machine name
      if gcode$ = 1052, sopen_prn, scomm$, sclose_prn, e$  #Group comment
      if gcode$ = 1053, sopen_prn, scomm$, sclose_prn, e$  #Group name
      if gcode$ = 1054, sopen_prn, scomm$, sclose_prn, e$  #File Descriptor

Share this post


Link to post
Share on other sites
5 minutes ago, Temores2790 said:

I need help with my post

1) What is the base post?

2 Has it been previously edited?

Share this post


Link to post
Share on other sites

This should normally work out of the box. Did you edit the comment section when doing the header?

Share this post


Link to post
Share on other sites

Is your ptoolcomment section missing? The pstrtool function just makes the comment uppercase.

ptoolcomment    #Comment for tool
      tnote = t$, toffnote = tloffno$, tlngnote = tlngno$
      if tool_info = 1 | tool_info = 3,
        [
        pstrtool #Convert strtool$ to uppercase if string is not empty
        scomm_fx_arg = strtool$ + sdelimiter + drs_str(2, tnote) + sdelimiter +
          drs_str(2, toffnote) + sdelimiter + drs_str(2, tlngnote) + sdelimiter + drs_str(2, tldia$)
        pcomment_out #Check comment length and output to NC file
        ]

 

Share this post


Link to post
Share on other sites
On 1/20/2020 at 7:06 AM, Kalibre said:

Is your ptoolcomment section missing? The pstrtool function just makes the comment uppercase.

ptoolcomment    #Comment for tool
      tnote = t$, toffnote = tloffno$, tlngnote = tlngno$
      if tool_info = 1 | tool_info = 3,
        [
        pstrtool #Convert strtool$ to uppercase if string is not empty
        scomm_fx_arg = strtool$ + sdelimiter + drs_str(2, tnote) + sdelimiter +
          drs_str(2, toffnote) + sdelimiter + drs_str(2, tlngnote) + sdelimiter + drs_str(2, tldia$)
        pcomment_out #Check comment length and output to NC file
        ]

 

thanks!! that was the problem!!! I fixed 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us