Recommended Posts

I may be posting this in the wrong forum, but this seems to me to be the place where I would get the most knowledgeable response for this issue.

I'm trying to incorporate the min max fix described here:  https://kb.mastercam.com/KnowledgebaseArticle50303.aspx , into our setup sheet.

 

I'm not a coder, so I just copied & pasted the script into our setup sheet(I'm pretty confident I have it in it's proper place), but I'm getting a bunch of errors saying that the following don't have definitions: txtMinX, txtMinY, txtMinZ, txtMaxX, txtMaxY & txtMaxZ.

 

Can anyone tell me how I can define these?

 

 

Share this post


Link to post
Share on other sites

Those are the names of the textboxes on the report, make sure you are using the same name and not the default, something like textbox1, etc.

  • Like 1

Share this post


Link to post
Share on other sites
24 minutes ago, Mick George said:

Those are the names of the textboxes on the report, make sure you are using the same name and not the default, something like textbox1, etc.

Ok, that got rid of the errors for the Z min max, but I'm still getting the X & Y errors. Can I just delete the sections of the script that reference them?

Share this post


Link to post
Share on other sites
4 minutes ago, Mick George said:

If you don't need them in the script, yes.

Well, I couldn't figure out how to do that without breaking it. So, I just created non-visable text boxes with the X & Y calls.

It's working now :animier:

Share this post


Link to post
Share on other sites
6 minutes ago, So not a Guru said:

It's working now

I spoke to soon. The report is generating now without errors, but the incorrect Min Z & Max Z output is unchanged.

Share this post


Link to post
Share on other sites

 

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Peter from S.C.C.C. said:

 

Thanks, I already had the tips & tricks document, but was unaware of the secret handshake having unlisted tags. I'm going to see what I can do with this.

Zeke

Share this post


Link to post
Share on other sites
Posted (edited)

Holey moley! I've been fighting this for a while and the fix was simple as could be once I had the full list of tags.

Set the Datafield for Max Z to MAX-Z-TPLANE & for Min Z to MIN-Z-TPLANE. It works perfectly now. And I saved the entire tag list as a pdf for future reference.

There is no need for the script at all.

Edited by So not a Guru
clarity
  • Like 2

Share this post


Link to post
Share on other sites
58 minutes ago, So not a Guru said:

Holey moley! I've been fighting this for a while and the fix was simple as could be once I had the full list of tags.

Set the Datafield for Max Z to MAX-Z-TPLANE & for Min Z to MIN-Z-TPLANE. It works perfectly now. And I saved the entire tag list as a pdf for future reference.

There is no need for the script at all.

:thumbsup:

Share this post


Link to post
Share on other sites

FYI, all tag definitions are located in Mastercam's Help and are updated for each release as new tags are added.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us