Recommended Posts

Im trying to section out my code for an upcoming part. This is a basic program that is using a 3 axis vertical mill. I used section NCI on this program then import it back into mastercam. After importing it back in I go to post the code on each process but I get an error "ERROR- SELECT MACHINE ACHIEVABLE TOOLPLANE WITH Y-AXIS ALONG MACHINE Y - SET AND REPOST" 

Ive gone back through my program and made sure that my planes are correct. They are all set to top. I even went back through and re-selected my chains for my toolpaths. Since im only using a 3 axis mill and programing from the top plane, I cant see what else I could do to fix this. vie attached my file below with out the broken nci files attached 

Any suggestions? 

MILL MEMORY TEST online.mcam

Share this post

Link to post
Share on other sites

As you didn't provide a z2g I can't test against your post but my 4 axis posted this with no issues at all

Try again with a z2g file and perhaps a different result can be found

Share this post

Link to post
Share on other sites

No issues again, even using your post...

Have you tried restarting Mastercam?

Strange one indeed


Share this post

Link to post
Share on other sites

I did not...not something I have ever had to use...


That said, just went in and did the 1st tool at 64k and got 7 errors



Share this post

Link to post
Share on other sites

Well the problem is that hasp only has lathe not mill. You cannot post Mill Programs with a Lathe only Hasp. I show no products listed for mill on the HASP report. Need to get a hold of your dealer and get an idea what your company has purchased to see what HASP you have that will allow you to post mill programs. Fact nothing shows up for mill puzzles me.


MILL: X - 
LATHE: X - Level 1
WIRE - None
ART - None
MCforSW Mill - None
MCforSW Lathe - None


Solids: true
FiveAxis: false


  • Like 1

Share this post

Link to post
Share on other sites

What version of Mastercam are you using?

I get the same errors you are getting, when trying to Post out the 'Sectioned' NCI Files.

I tried to duplicate your results (by sectioning the 174 Kb Dynamic Path). I had to search through the "unused commands", as "Import NCI" is no longer listed under the Right-Click Menu in the Ops Manager.

I got the same error message when I posted "your Sectioned NCI" and "my new Sectioned NCI" data.

However, the Code does seem to Post in the Text Editor OK, after saying "yes" to the warnings.

I even did an experiment, where I opened your 4X Machine Definition, and added 2 additional VMC Rotary Axes to the MD, to make it a 6-Axis Machine. (Similar to MPFAN), which technically should be able to machine "any plane inside Mastercam", with the combination of 3 rotary axes.

This is for sure a bug, but it doesn't seem to be unsurmountable, since you do get Posted code out at the other end. It sure doesn't give the user much confidence though, when you are getting 2 error warnings per NCI File being Posted...

I would recommend making a Zip 2 Go package, and sending it to [email protected] (CC your Reseller when you do...)


  • Like 2

Share this post

Link to post
Share on other sites

I think colin is correct on his assessment and I went ahead and opened ticket 34890 for this.

  • Like 3

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us