Jump to content

Welcome to eMastercam

Register now to participate in the forums, access the download area, buy Mastercam training materials, post processors and more. This message will be removed once you have signed in.

Use your display name or email address to sign in:

lathe peck drill error

Recommended Posts

See the below code snip. Anyone else have this problem, and have a solution? When peck drilling in Mastercam Lathe, the peck increment basically decreases to infinity, making for VERY long files... This same problem has followed me from multiple versions since at least 9. It does not appear to be post related, as a brand new post still causes the error. Only thing I have ever found to eliminate the problem is change the hole depth. But that does not always work. 2nd peck, retract etc, none of them change the error. 

N100 G20
/ TEMP /
/ DRILL 1 /
/ / DRILL /
N110 G0 X1.0 Z6.0
N120 G0 T0606 M41
N130 G97 S200 M03
N140 G0 X0. Z.05 M9
N150 G99 G1 Z-.2 F.01 <First Peck is 0.25 deep, 
N160 G0 Z.05
N170 Z-.2
N180 G1 Z-.45 <0.25 peck
N190 G0 Z.05
N200 Z-.45
N210 G1 Z-.65 <0.20 peck
N220 G0 Z.05
N230 Z-.65
N240 G1 Z-.81 <0.16 peck, Subsequent pecks keep getting shorter, until they are 0.0001" eventually
N250 G0 Z.05
N260 Z-.81
N270 G1 Z-.938
N280 G0 Z.05
N290 Z-.938
N300 G1 Z-1.0404
N310 G0 Z.05
N320 Z-1.0404
N330 G1 Z-1.1223
N340 G0 Z.05
N350 Z-1.1223
N360 G1 Z-1.1879
N370 G0 Z.05
N380 Z-1.1879
N390 G1 Z-1.2403
N400 G0 Z.05
N410 Z-1.2403
N420 G1 Z-1.2822
N430 G0 Z.05
N440 Z-1.2822
N450 G1 Z-1.3158
N460 G0 Z.05

Link to comment
Share on other sites
  • 1 month later...
On 12/1/2020 at 1:46 PM, nickbe10 said:

Which base post? Looks like it is set up for longhand drill....?


Yes. I can ONLY longhand drill on the control. Very frustrating.

Base post would be MC version 9. But even when I start with a clean MC post it still happens, but not consistently. 

Link to comment
Share on other sites
5 hours ago, Colin Gilchrist said:

In the Control Definition File, there is a setting for 'Peck Reduction', on Longhand Drilling Cycles. I think the default is 99%, which decreases the peck amount by a tiny bit, each Peck.

Set that to 100%, so the pecks stay the same increment.


Thank you. It was set to 80%. Changed to 100% and fixed it for now. Now I know where to look if it comes back again. 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us

  • Create New...