Sign in to follow this  
Corey Hampshire

Hollow Stock Model after P-mesh conversion

Recommended Posts

Good morning. I was wondering what I am doing wrong when I do a p-mesh wash. Here are the steps that I use to create my stock models that result in a hollow stock model.

Select operations and run verify. Save stock as .stl in verify. Create a new level in Mastercam. I import ops, so the stock model op is already in my toolpaths list. I then create the stock model off a file, and navigate and select my newly created .stl file. Stock model creates. Toolpath tab/stock model/convert to pmesh. Once the P-mesh model is created, I go back in stock model and select model for initial stock shape.

Sometimes all this works, other times it does not. I have found that if I verify off a previous stock model, after two or 3 or 4 times of this I get one that is hollow. My fix has been to just reverify all the ops from the beginning and that usually takes care of it.

This is not the case today, as I have one that will not work no matter what I do. It is hollow. What did I miss? Is there a work around? This is in Mastercam 2021, update 3.

Share this post


Link to post
Share on other sites
1 hour ago, Corey Hampshire said:

Good morning. I was wondering what I am doing wrong when I do a p-mesh wash. Here are the steps that I use to create my stock models that result in a hollow stock model.

Select operations and run verify. Save stock as .stl in verify. Create a new level in Mastercam. I import ops, so the stock model op is already in my toolpaths list. I then create the stock model off a file, and navigate and select my newly created .stl file. Stock model creates. Toolpath tab/stock model/convert to pmesh. Once the P-mesh model is created, I go back in stock model and select model for initial stock shape.

Sometimes all this works, other times it does not. I have found that if I verify off a previous stock model, after two or 3 or 4 times of this I get one that is hollow. My fix has been to just reverify all the ops from the beginning and that usually takes care of it.

This is not the case today, as I have one that will not work no matter what I do. It is hollow. What did I miss? Is there a work around? This is in Mastercam 2021, update 3.

You are better making a stock model using the starting stock and then using the operations to define it. Then save that stock model out as a Pmesh. Either make a new stock model from that point or choose the Pmesh as the source for that point in time stock model and unselect the source operation used to make that stock model using the ctrl button. Other thing is to use looser tolerances on your stock models. I know some people want .0001" stock model not what is what made for unless the part is the size of a quarter.  I have some large parts using .02 toelreance on my stock models and they are water tight. The tighter the tolereance the harder it is to make them water tight. The looser the better.

You are using the Pmesh wash as we call if from Verify so the only thing I can tell you in that method is loosen the tolerance and see if that helps make it watertight. Yes it can be a fight and where I use Model prep to make good solids of operations to use that solid for my stock models. More work maybe, but I have something I know works.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Ron. Thanks for the reply. I use the P-mesh style because when I try to drive the stock models off of the initial stock and subsequent ops, Mastercam will crash on me. It's not 100% of the time, but when I get into a lot of ops, it crashes.

I opened the tolerance from .001 to .002 and was able to create a watertight solid. That was enough to fix my issue. Is there a way to set the default tolerance to something other than .001? I agree that I don't need the stock models that accurate, and I am sure it would cut down on computation time. 

Share this post


Link to post
Share on other sites
2 hours ago, Corey Hampshire said:

Hi Ron. Thanks for the reply. I use the P-mesh style because when I try to drive the stock models off of the initial stock and subsequent ops, Mastercam will crash on me. It's not 100% of the time, but when I get into a lot of ops, it crashes.

I opened the tolerance from .001 to .002 and was able to create a watertight solid. That was enough to fix my issue. Is there a way to set the default tolerance to something other than .001? I agree that I don't need the stock models that accurate, and I am sure it would cut down on computation time. 

Yes operational defaults control that tolerance. Stock models are hit or miss for the most part and we all develop what helps us get the job done. I will section the STL files using Verisurf Reverse from time to time. We are getting more STL editing options in the future and it should help is situations like this where we need to refine the pmesh or trim it to just what is needed and eliminate excess features not needed for calculations. That trick has saved me countless hours on big files only using what I need. Another thing is don't pick the whole solid for toolpaths if only machining a section of the part. Pick what you need and toolpath calculation times go down greatly also. Keep the process and method simple as possible for the software. Yes may mean more work for the the programmer making levels and picking only 300 faces out of 30000 faces, but start doing some complex work and not having to wait for long periods of time makes that extra work well worth the time spent.

Drives me crazy when someone is machining the top section of a 42" tall part and grabs the complete solid then wonder why it takes 4 hours to calculate a toolpath when if they just grabbed that upper section it only takes 15-20 minutes. Mastercam is not good when Mastercam is doing exactly what they told it to do. Not different here making the tolerance too tight when not needed makes everything take longer and create issues that are not value added. That was not directed at you Corey just an general observation.

Share this post


Link to post
Share on other sites

I understand what you are saying Ron. When I first started using the software back in X5, I used to select the whole part. Like you said it would take forever to do tool paths. Since I went to training and was explained some things, I have treated it differently. I use the crap out of quick masks and colors. I window select solid faces for speed. I only select what I need and the same with collision checking. 

I have greatly increased the number of ops from the previous programmers. I have more control of the tool paths and I make better parts. You are 100% right that it is more work on my end, but the end result is better. 

I will dig up the operation defaults and set the stock models as I see fit. It should help reduce some frustration in the future. As always, thanks for the help!

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us