Sign in to follow this  
Metallic

Mastercam Vericut Interface

Recommended Posts

Hey guys

 

I am having trouble with teh Mastercam to Vericut interface, which is causing headaches. Our IT can't figure it out, and Vericut can't figure it out. Either way, the interface ain't playing nice.

 

Is there any way to import Mastercam tooling data into Vericut manually, so that I don't need to build out a tool library in Vericut. Has anyone ever done this?

 

Thanks as always.

Share this post


Link to post
Share on other sites
2 minutes ago, Metallic said:

Hey guys

 

I am having trouble with teh Mastercam to Vericut interface, which is causing headaches. Our IT can't figure it out, and Vericut can't figure it out. Either way, the interface ain't playing nice.

 

Is there any way to import Mastercam tooling data into Vericut manually, so that I don't need to build out a tool library in Vericut. Has anyone ever done this?

 

Thanks as always.

You can export all the holders and tools to levels and then export as a dxf then use the dxf to build the tools in Vericut, but going to be some work. I use the interface all the time and not had issues. What specifically are you running into? 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 minute ago, crazy^millman said:

You can export all the holders and tools to levels and then export as a dxf then use the dxf to build the tools in Vericut, but going to be some work. I use the interface all the time and not had issues. What specifically are you running into? 

Basically when you try to run the interface, nothing happens. Initially it was throwing an error about the location of some system variables. We set the LSHOST variables correctly and now it does absolutely nothing when you click "run"

It only happened when I moved from 2022 Mcam and Vericut 9.2. Clicking that interface run does nothign!

image.png

Also on the backend IT side, they moved to a new server situation which I claim caused the issue. Of course IT geniuses say that is simply impossible even though it was working before.

Share this post


Link to post
Share on other sites

How about the CGTECH_INSTALL and GCTECH_PRODUCTS values? Where they pointed to the local system or to the network? LSHOST is best set through the Vericut Utilities Specify License server Name. The IT people should be able to ping that location using a command prompt from your workstation. If they cannot ping that specific location then you are 100% correct it is an IT issue plain and simple.

image.png.6358a3be4867da00a558e36d498a8751.png

There is the Sentinel License Admin tool that will help IT sort out the Defined server location also. Has anyone run it?

image.png.9e19327e972b276a8e19d394b12719b4.png

I have a local server so all I can access shows with no issue, but the defined servers will show IT that your workstation can see the server to access the license. If this is not accessing the server correctly then this will create an issue.

image.png.bcd1a6e01526f53d8e82d2630fa053d1.png

  • Thanks 1

Share this post


Link to post
Share on other sites
23 hours ago, crazy^millman said:

How about the CGTEXH_INSTALL and GCTECH_PRODUCTS values? Where they pointed to the local system or to the network? LSHOST is best set through the Vericut Utilities Specify License server Name. The IT people should be able to ping that location using a command prompt from your workstation. If they cannot ping that specific location then you are 100% correct it is an IT issue plain and simple.

image.png.6358a3be4867da00a558e36d498a8751.png

There is the Sentinel License Admin tool that will help IT sort out the Defined server location also. Has anyone run it?

image.png.9e19327e972b276a8e19d394b12719b4.png

I have a local server so all I can access shows with no issue, but the defined servers will show IT that your workstation can see the server to access the license. If this is not accessing the server correctly then this will create an issue.

image.png.bcd1a6e01526f53d8e82d2630fa053d1.png

Theyre taking a look at it now. I forgot to mention (pretty importantly) that Vericut does work on its own, it is merely the Mastercam interface causing issue.

Share this post


Link to post
Share on other sites
1 hour ago, Metallic said:

Theyre taking a look at it now. I forgot to mention (pretty importantly) that Vericut does work on its own, it is merely the Mastercam interface causing issue.

I would then suspect the chooks folder inside the Mastercam 2022 folder needs to be given full permissions. I tell all IT people give the Mastercam folder in program files full rights. They normally freak out thinking they are giving everything away when they are only giving the folder full permission to run like it should.

  • Like 1

Share this post


Link to post
Share on other sites

I've had the same type of problems with the interface due to permissions in C:\Program Files.  My solution was to install MC and Vericut it their respective folders in C:\.  Problems went away.

Share this post


Link to post
Share on other sites
1 minute ago, savagkd said:

I've had the same type of problems with the interface due to permissions in C:\Program Files.  My solution was to install MC and Vericut it their respective folders in C:\.  Problems went away.

Easier way is just give the correct permissions for the Folder inside of program files.

image.thumb.png.6b213a7b7e710fe526f989171e75d1a9.pngimage.png.e3c55af0708c971f7f4ffc1002892e80.png

Share this post


Link to post
Share on other sites

Wish I could.  IT has it locked down.  I'd have to have them change the permissions.

 

Share this post


Link to post
Share on other sites
48 minutes ago, savagkd said:

Wish I could.  IT has it locked down.  I'd have to have them change the permissions.

 

Yes ignorance of most IT people is thinking they are giving away the farm doing such a thing. It is only for a folder for a program to run it best not the end of the world and not full permissions to the complete system or the internal network inside of the company.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us