Sign in to follow this  
Bobnob

Just trying to close a file

Recommended Posts

Hello to everyone. I'm new to X6 in that I haven't touched Mastercam since v9, but have been using CAD for a while and have used many packages over the years. That said, I've never had so many problems doing the simplest things. Having worked for a software reseller, I am very hip to the fact that software companies aren't necessarily interested in fixing everything that's wrong with a particular version or release. But X6 is about as fun to deal with as wiping your rear with sandpaper.

 

Even the simplest of operations, saving, never goes right every time, and i find this totally unacceptable. I'm currently using x6 mu3. The biggest issue for me is data loss during saving.

 

Lets say I have file A open, and want to open file B. File A was just saved, but it prompts me to save again before opening file B. If I click yes, sometimes (not predictably) it saves file B as file A. So when I reopen file A, it really contains everything from file B. If I click no, it will do the same thing. Again, i cannot reproduce this on demand as software companies would typically require to investigate.

 

If I have file A open, and want to create a new file, it does the same thing, but not predictably. I choose to save file A, when prompted, before creating a new empty file. File A will then sometimes be completely empty as if I saved the blank file over file A. Again I cannot predict when it will do this.

 

Has anyone experienced anything similar to this? Without auto backups, I'd have been totally screwed and looked like an idiot to my boss. I'll own a problem if it's my fault, but this isn't one of 'em.

 

Frustrated,

Bobnob

Share this post


Link to post
Share on other sites
Guest

Yeah, Mastercam really stinks like that, it's amazing anyone gets anything done at all

Share this post


Link to post
Share on other sites

I also have always ignored disclaimer that pops up about masterCam not suporting multiple instances.

Share this post


Link to post
Share on other sites

I appreciate the responses, but I'm more after corroboration that this IS in fact a Mastercam issue. I have not closed the door on other suspects, such as our network, which was switched over to active directory within the last 6 months. That said, I have no issues saving files outside of Mastercam...CAD models, spreadsheets, etc.

 

Bobnob

Share this post


Link to post
Share on other sites

People have complained about the saving over the wrong file thing. I think most people are in the habit now of closing a file before opening another one. Shouldn't have to, but it's safer. Also, if you turn on backup files you'll have something to recover if it does happen to you.

Share this post


Link to post
Share on other sites

I appreciate the responses, but I'm more after corroboration that this IS in fact a Mastercam issue. I have not closed the door on other suspects, such as our network, which was switched over to active directory within the last 6 months. That said, I have no issues saving files outside of Mastercam...CAD models, spreadsheets, etc.

 

Bobnob

 

Hi Bobnob and welcome to the forum.

 

I am running the same version as you, and I have not had this experience. Never had trouble saving/overwriting files. Typically I will open a file after saving my current file. If it asks if I want to save, and I choose yes, it prompts me for where and what filename to save to so wouldn't it be my fault if a file got overwritten? I know a lot of people had a lot of issues with the early release of MCX-6. I didn't jump on x6 til MU3 was released and I am generally happy with it. Hope you can get your problems cleared up soon!

Share this post


Link to post
Share on other sites

This has been a semi-regular issue with me. I don't remember having that problem in X5, and don't think its happened in X7.

It's exacerbated in X6 when saving to a network, but not limited to.

 

At first I thought I was just mental. I'm AN-AL about saving, but maybe I forgot to save this time ? (again ?!). But when I finally saw one day, that I had a saved file of posted GCode, including ops that were 'missing' when I reopened the Mcx file back up, I knew.

 

Just today, exactly what you spoke of happened.To make sure files are not overwritten from an 'errant' close, I will always do a SAVE, then a SAVEAS, before closing a file. But when I went to close the file, it STILL asked me if I wanted to save my changes. I of course said yes. When I opened the file back up, I could see ops were missing. :/

 

I've also had this problem with a couple of other CAD Apps, on different PC's

 

I don't use the 'autobackup' function, I save off duplicates, (Using MasterCam's function), and have it set to 100 files. but when it doesn't save the original, it doesn't save the backup.

 

In fairness, I'll say no one else in our Engineering Dept has this problem.

 

So they don't think I'm mental, just reckless :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us