Sign in to follow this  
goldhntr

tool number and dia. offset number

Recommended Posts

I have recently upgrade to X7 and I am having a problem with the tool number, lenght offset number and the dia offset number. I would like the default for these to all be the same. this worked flawlessly in X6 and doesn't seem to behave that way in X7. I have some tool path libraries that I have been managing over time and regularly import them into new parts. They used to automaticly get assigned the next tool number in order that was available in the part program and the length offset and dia offset would also be assigned that same number. How do I get X7 to behave that way? I have tried to using the "renumber tools" in the operations manager, but I still don't seem to be able to get the length offset value and the dia offset value to be the same as the tool number. I have been dithering with parameters in the control definition and the tool setting page of the Machine group properties with no results. Any advice?

Share this post


Link to post
Share on other sites

Hi Mike,

 

You can add a Global Formula to you post that will override the settings in Mastercam.

 

At the top of your post, add the following two lines of code, starting in the first column:

 

tloffno$ = t$

tlngno$ = t$

 

That will make your diameter and length offset numbers always match your tool number.

 

Hope that helps,

 

Colin

Share this post


Link to post
Share on other sites

I have found in X7 that you have to go into the control definition and under tool set the "tool offset registers" to "add to tool" and make both the length and diameter 0. as for the sequential tool numbers just go into your machine group properties and under tools turn on the assign tool numbers sequentially.

Share this post


Link to post
Share on other sites

dowlinzg

 

I have already done that. That was how I had it configured in all prior versions of X. It has worked fine up till now

Share this post


Link to post
Share on other sites

Check that it has not switched back, this was a problem before.

Share this post


Link to post
Share on other sites

Hi Mike,

 

You can add a Global Formula to you post that will override the settings in Mastercam.

 

At the top of your post, add the following two lines of code, starting in the first column:

 

tloffno$ = t$

tlngno$ = t$

 

That will make your diameter and length offset numbers always match your tool number.

 

Hope that helps,

 

Colin

 

Colin, can you elaborate please? I am a novice post editor at best. Where would the "top of the post" be exactly?

 

Thanks

Share this post


Link to post
Share on other sites

Has anyone figured out the correct, simple way to remedy this yet? I have the exact same issue as the OP. It is quite annoying. I always go over the programs with a fine tooth comb when they are originally posted, and catch this. However, when I am going back to a job months later to re-post an altered tool, I have overlooked the error not expecting anything like that to be present in an already run program... You can imagine how well that goes.

 

Thanks,

Lans

Share this post


Link to post
Share on other sites

The solution I mentioned with a quick post fix would solve this so that the toolpath settings are ignored, thus preventing you from ever having an issue.

 

Sorry I missed the question from Left Coast Lefty before.

 

The proper place for a Global Formula is to put them above the variable initializations. These are basically "global equations". So above where the "constants" and other variables are defined. The global formula must start in the first column, with no other characters in front of the variable that begins the equation.

 

Here is the top section of the Generic Haas 4X Mill Post, unedited:

 

#
# END_HEADER$
#
# --------------------------------------------------------------------------
# Debugging and Factory Set Program Switches
# --------------------------------------------------------------------------
#Define Constants
m_one	 := -1
zero		 := 0
one		 := 1
two		 := 2
three	 := 3
four		 := 4
five		 := 5
c9k		 := 9999
bug4$	 : 1	 #Debug output with the tilde '~'.
				 #A value greater the zero applies the variable formatting with
				 #debug output (default is typically FS 1 but not a guarantee).
				 #A value of zero gets the value directly with NO formatting.

 

Here is the same code, but with the additions of the global formulas for "tool offsets" always equal the "tool number":

 

#
# END_HEADER$
#
# Global Formula to set Tool Offsets always equal to the Tool Number


tloffno$ = t$
tlngno$ = t$


# --------------------------------------------------------------------------
# Debugging and Factory Set Program Switches
# --------------------------------------------------------------------------
#Define Constants
m_one	 := -1
zero		 := 0
one		 := 1
two		 := 2
three	 := 3
four		 := 4
five		 := 5
c9k		 := 9999
bug4$	 : 1	 #Debug output with the tilde '~'.
				 #A value greater the zero applies the variable formatting with
				 #debug output (default is typically FS 1 but not a guarantee).
				 #A value of zero gets the value directly with NO formatting.

 

 

Global formulas are evaluated just prior to the variables that are being output.

 

Since both 'tloffno$' and 'tlngno$' are used in the post to output the values of D and H, those variables normally receive their values from the values written to the NCI file. A global formula will always override the current value of the variable. For this reason they need to be used with caution, because their behavior makes it difficult to do debugging on the post output. When debugging you'll see the current value of the variable, but just before output the global formula is consulted (if one exists), and the value is changed just prior to output.

 

In the case of this particular Mastercam issue, this global formula is a good thing. Because it always works to force the offset values to equal the tool number.

 

If you sometimes have different T/H or T/D values (on purpose), then you do not want to make this change.

 

If you always want your Tool Numbers and Tool Offset numbers (T, H, D) to always match, then this change will accomplish that and be rock solid.

Share this post


Link to post
Share on other sites

Speaking of tool numberin' and offset values,...

Got a VTL with no tool changer, same tool is being used for the OD & ID by crossing over center.

The Mcam turning tpaths don't like having a tool loaded with matching tool numbers even though the offset is different.

I was able to setup the turning tools to output correct value by setting OD to the upper turret and ID to lower but still fighting with the tool numbering.

Share this post


Link to post
Share on other sites

Thank you for the response and post information Colin. That is vey helpful.

 

I spoke with my reseller for a while yesterday and it appears the issue is that X7 does not force a regeneration of the toolpath that you change the offset values in. If there are multiple toolpaths using that tool, it will force regeneration of the following toolpaths but not the initial one changed.

 

After changing and re-ordering the tool numbers, select the entire toolpath group and do a regeneration. That fixed it.

Share this post


Link to post
Share on other sites

There are several ways to change the offsets for an operation (i.e. edit common parameters, edit box in the toolpath parameters page, clicking on the tool in op manager etc.) I did some testing and I found that if I edit the offsets by clicking on the tool in the operation manager the offsets didn't update without a regen. If I change the offsets in the operation parameters it worked fine. That may explain why it's working for one person and not for another. I will test all the different workflows I can think of and enter a defect so we can take a look.

Share this post


Link to post
Share on other sites

There are several ways to change the offsets for an operation (i.e. edit common parameters, edit box in the toolpath parameters page, clicking on the tool in op manager etc.) I did some testing and I found that if I edit the offsets by clicking on the tool in the operation manager the offsets didn't update without a regen. If I change the offsets in the operation parameters it worked fine. That may explain why it's working for one person and not for another. I will test all the different workflows I can think of and enter a defect so we can take a look.

 

does this mean if its a bug, we will get a patch?

 

I could direct you to a bunch of bug threads and you can clean

a ton of unfinished bidness up :)

  • Like 1

Share this post


Link to post
Share on other sites

does this mean if its a bug, we will get a patch?

 

I could direct you to a bunch of bug threads and you can clean

a ton of unfinished bidness up :)

Holllllllllllllldddddddddddd on there Tiger. You know you can't rush these things...

:D

Share this post


Link to post
Share on other sites

does this mean if its a bug, we will get a patch?

 

LOL Nope it means it will get done for X8. :laughing::scooter:

  • Like 1

Share this post


Link to post
Share on other sites

LOL Nope it means it will get done for X8. :laughing::scooter:

 

We ALL know how CNC works......... :fun:

 

BTW, if X8 is built from the ground up, How,may I ask,

did PRE X version bugs manage to linger into it...... :harhar::whistle:

Share this post


Link to post
Share on other sites

BTW, if X8 is built from the ground up, How,may I ask,

did PRE X version bugs manage to linger into it...... :harhar::whistle:

You should know by now that they aren't bugs but features.

If they were bugs they'd get written out at each release.

The fact that some are there for multi releases means they MUST be features :lol:

Share this post


Link to post
Share on other sites

I know that this is an old topic but I found the other day that this problem re-surfaced in Mastercam 2018. Thought I'd post a fix that worked outside of the post edits for me.

Under Machine Definition enter your Control Definition menu and click on the 'Tool' section. Under 'Tool offset registers' check 'Add to tool' and enter zero in both fields.

Then under the 'Tool number options (post)' section make sure the 'Use the head number to 'add' for the offset registers' box is checked as well. Then save your control and machine definitions.

Once assign tool numbers sequentially is checked in your tool options this should solve the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us