Jump to content

Welcome to eMastercam

Register now to participate in the forums, access the download area, buy Mastercam training materials, post processors and more. This message will be removed once you have signed in.

Use your display name or email address to sign in:

Hermle C400 problems


mill programmer
 Share

Recommended Posts

Hi All. I'm working on a Hermle C400 5 axis mill. Heidenhain i530 control. Ocasionally this machine goes to the wrong position. This isn't a wreck, but for example, yesterday I had a toolholder cut right through a titanium part. This doesn't show up in the software simulation. I've had the nc verified in Veri-cut, no collision. This has been a tough thing to diagnose. I've had multiple conversations with Application engineers to no avail. As far as I can tell the problem has something to do with the kinematic calculations. It only shows up during a 5 axis toolpath. We had the machine tech come to the shop and check the geometry and re-calibrate everything. For the most part this is a very nice machine but it has scrapped parts 3 times now. I've also spent days with the software people (Openmind - Hypermill) thinking that was the source of my problem. It seems like the problem is with the machine. Anyone out there having similar problems? Any insight would be greatly appreciated.

Thanks

Link to comment
Share on other sites

I run an older iTNC530, on a Mikron HSM 400u machine, and was told about, and experienced once the following...

 

I was told in 5 axis toolpaths, that for any given point in space, there are (2) solutions, and sometimes the control will jump from one solution to the other, and the part can flip over or swing around wildly.

 

I had this happen to me once, and luckily it did not crash the machine, but scared the snot out of me...

 

 

 

An example is as follows:

 

Say you are doing some 5 axis movement, (XYZBC in my case).

 

You are at a location, say X-1.0, Y+0.0, Z+2.0, B-90, C0.0

 

Your next move is say to X-1.0, Y+0.0, Z+3.0, B-90, C0.0

 

From the point you are at, to the point it is to move to, it should move Z positive 1.0, and that is it.

 

 

 

Nothing else should really happen, especially no B or C movement.

 

 

 

But, the machine flips the part around and over from B-90, C0.0 to B+90, C180…

 

 

 

So, it went from X-1.0, Y+0.0, Z+2.0, B-90, C0.0

 

to X+1.0, Y0.0, Z+3.0, B+90, C180…

 

 

 

Take a look at the numbers above carefully.

 

The tool was in X negative, and it jumps to X positive.

 

The B axis was at B negative, and now it is at B positive

 

The C axis was at C0, and now it is at C180.

 

It is due to the kinematics, as you said…

 

 

Scary stuff…

 

So, on my iTNC530, what I did to eliminate this possibility, was I locked down (with a parameter), my B axis, so that it can ONLY move from B0 to B-90, and not from B-90 to B+90 (My machine can swing from B-90 to B+90, and it has full 360 degree rotation about the C axis.)

 

On the newer iTNC530's, there is a setting that will force the same thing, essentially locking the B axis (or any other axis) to movement in a positive only or negative only direction.

 

I believe it is in the "PLANE" functions. It is called "PLANE SPATIAL"

 

I have to look this up, but you might contact Heidenhain and ask them about it…

 

Heidenhain Service support center: 847-490-0351

 

 

Depends on the software version of your control…

 

PM me, and give me your phone number, and I will call you, to try and explain it better than I have here…

Link to comment
Share on other sites

Hi Niezingerly,

Thanks for your reply. I know what you referred to. That isn't my problem unfortunately. Although that did scare the poo outa me too one day! My problem is the machine reads the correct nc and randomly goes to the wrong position. I've ran the same nc in another machine (DMG) and it runs fine. So I believe something is wrong with the machine. No one with Hermle understands this and keeps pointing to the software as the problem.

Link to comment
Share on other sites

few questions

are you using cycle 19 or plane spatial?

cycle 19 will give you random movements whereas plane spatial will go to the actual programed #'s. i had the same problem with the machine movement in cycle 19 ( scrapped a $40,000 part), changed to plane spatial and every thing is honky-dory now.

is the kinematics forcing the rotation of the B axis towards the operator?

Link to comment
Share on other sites

Thanks for the replies. The toolholder collision was because I used an A axis offset when I set-up the job. I didn't know until now that I can't do that if I'm going to rotate the C axis. So, that part of my problem is corrected.

 

I am having another problem however. I've made parts with holes that are tipped on very shallow angles and the holes are off location by a lot. Some are more than .030 inches off location in one direction. I'm not using cycle 19. Using plane vector instead. I can force the b axis (actually a axis on this machine) positive or negative. The positional errors occur both ways. What's interesting is all 5 axis milling toolpaths perform very accurately. But the 5 axis positioning is incorrect when the A axis is tilted very slightly - less than .1 degrees. I've been told there is only 1 kinematic file which is used for all of the A and C axis moves, which is why it's been so difficult to determine what the problem is. Positioning at larger degrees such as 2,10,45,90, etc. and it goes to the correct position.

We have another machine here with the same control. I posted the same toolpaths for that machine and the holes come out fine. Everyone I talk with says they have never heard of this problem. At this point I believe I have a machine problem. I just don't know what to do about it. Neither does the manufacturer at this point.

Link to comment
Share on other sites
  • 2 months later...

It turns out the reason for the holes being in the wrong location was due to the post processor output not being correct. The machine was going to the exact position the program told it to go. This was a rare and complex issue to deal with compounded by the difficulty of being able to look at the code and knowing where a problem might be and/or where the machine is going to move.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us

×