JNg

mc2018 freezing

Recommended Posts

hi all. new here, looking for some solutions or possible new ideas we haven't tried yet. 

got a new system, acer predator with win 10 pro (and home in another workstation) geforce gtx 1070, tried running mc2018 and it's crashing/freezing about 5-10 min in.

previous old workstation worked fine with x8, x9, 2017, and 2018 too. uninstalled off old machine to install on new machine (only one seat for our company) and it crashes. also had lower geforce gtx 970, radeon 6450, and gtx 640 cards previously. 

things we've tried: 

  • update video card (released 09/29/2017)
  • update all windows patches/service packs
  • update 2018 patch 1 (released 08/29/2017)
  • update visual c++
  • update msoft .net framework
  • running part off of parts server and on local machine only
  • running simple box/rectangle type parts
  • turn off firewall / security settings
  • swapping out video cards with old ones or lower level ones
  • swapping out video cards with recommended one (mcam recommends nvidia quadro but doesn't specify which one? we tried the k620)
  • disconnecting from the servier
  • swapping out monitors to hdmi only
  • swapping out monitors to dp only

nothing works! it still crashes! that being said, we have it running 2017 fine, however the part its running is off the local machine, not off the server either. 

any help, tips, tricks or ideas are greatly appreciated!! TIA

Share this post


Link to post
Share on other sites

Not sure why you are crashing, but need to get your dealer involved and if they can help then escalated to QC at CNC to help out.

BTW Mastercam can be installed on a 1000 machines the hasp has the license to run it, not the install.

Welcome to the forum and hopefully you can get this resolved.

Share this post


Link to post
Share on other sites

I had a similar problem, 2017 worked fine... 2018 crashed frequently... it was solved by updating the software for the video card.

My card is a Quadro K4000.

Share this post


Link to post
Share on other sites

video card has the latest driver available already. we are thinking of getting a better quadro card if all else fails, just to try since at this point we have nothing to lose. is the k2200 acceptable to use ? 

thanks C^Millman for that info,  We did try installing 2018 on an older machine with gtx 640 and it seemed to work okay actually, just slow, that's all. 

 

Share this post


Link to post
Share on other sites

it should be noted also that we have contacted our reseller for help already and they were of no help. we are currently in talks with CNC to try to help but they're also just as confused/bewildered as we are in this. :(

Share this post


Link to post
Share on other sites
11 minutes ago, Jimmy Nguyen said:

video card has the latest driver available already. we are thinking of getting a better quadro card if all else fails, just to try since at this point we have nothing to lose. is the k2200 acceptable to use ? 

thanks C^Millman for that info,  We did try installing 2018 on an older machine with gtx 640 and it seemed to work okay actually, just slow, that's all. 

 

The K2200 would be a good card to try. I was just in your area today.

Share this post


Link to post
Share on other sites

Windows user permissions can get real funky with Win 10

Try creating a folder  outside your user files  like

"C:\MCtemp"

then go to the Files page of system config and route your temp files there

if you're doing a lot of surfacing work add a regen folder inside the MCtemp folder and path your regen files

to that folder

You should also clear your log file when you launch MC2018 and review it after a crash.

It may give to good clues as to what the problem is

Share this post


Link to post
Share on other sites

It could also be a bad install. Have you tried uninstalling Mastercam completely and reinstalling it?

Share this post


Link to post
Share on other sites

just an update: we had our reseller come in and try to figure it out and nothing he did or didn't do necessarily worked. the only thing we found to be completely bizarre, was that when connected to the internet, it worked fine, for a long time. even when disconnected from the internet with the same instance open, then it continued to work. however once we closed the program and opened it again, while still being disconnected from the internet, it then froze after about 5-10 minutes. 

there were no error pop ups, no freeze warnings or indicators from windows event log or mcam logs. there were a couple instances where mcam did in fact, crash, with a warning and the whole 'windows will attempt to find a solution' or 'windows is gathering data to resolve this' type and those crashes actually showed in the mcam log. 

our final resolution was to simply return the computer and try something else instead.

thanks everyone for your input and help! 

Share this post


Link to post
Share on other sites

Did they turn off the share and check for updates? I have had that crash Mastercam before when offline. Turned them off and got rid of the crashing.

Share this post


Link to post
Share on other sites

I think I know how to solve this

File/Community/Customer Feedback Program

I'll bet "Join the Mastercam Feedback Program" is turned on

and because you are not logged into the internet, it can't feed back, and locks up instead

Check the "I do not choose to participate " button

Problem solved ( I hope)

 

Share this post


Link to post
Share on other sites
9 minutes ago, C^Millman said:

Did they turn off the share and check for updates? I have had that crash Mastercam before when offline. Turned them off and got rid of the crashing.

our reseller tech tried looking for that, as well as the 'feedback data' thing where you send them logs of our usage but he said he couldn't find where it was located to do so. 

Share this post


Link to post
Share on other sites

How stable are quadro drivers with mastercam 2018? We just upgraded one of our computers (hasn't arrived yet) and it comes with an M2000. So should I be expecting trouble...

Share this post


Link to post
Share on other sites
30 minutes ago, JNg said:

our reseller tech tried looking for that, as well as the 'feedback data' thing where you send them logs of our usage but he said he couldn't find where it was located to do so. 

I'm sure this is the problem ...  I've see this behavior before

the switch is located at

File/Community/Customer Feedback Program

 

 

Share this post


Link to post
Share on other sites

The switch for turning off automatic update checks is at

File/Help/Check for Updates

Uncheck both boxes

 

Share this post


Link to post
Share on other sites

I get that same problems, after working a time, my mastercam freezes, then a try Run it as "Administrator rights", it works. No more freezes.

Share this post


Link to post
Share on other sites

I’ve been having the same exact problem with mastercam . It runs for a few minuets and then freezes . Has anyone found the solution? So far I’ve tried to turn off automatic updates and feedback . Neither have worked . Thanks .

Share this post


Link to post
Share on other sites
38 minutes ago, 3DGee said:

I’ve been having the same exact problem with mastercam . It runs for a few minuets and then freezes . Has anyone found the solution? So far I’ve tried to turn off automatic updates and feedback . Neither have worked . Thanks .

Get a hold of your dealer like I suggested to the original poster of this topic.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us