Jump to content

Welcome to eMastercam

Register now to participate in the forums, access the download area, buy Mastercam training materials, post processors and more. This message will be removed once you have signed in.

Use your display name or email address to sign in:

X+ for Mastercam


Recommended Posts

  • 3 weeks later...
On 3/17/2018 at 1:58 AM, Günther Massimo - GMCCS said:

X+ is updated for Mastercam 2019.

download

 

 

Hi Gunther

Trying to use the attached template file but it causes MC2019 to crash every time. This is a new template that I created through x+ in MC2019, but is laided out exactly the same as we have been using for the last few versions.

 

default - McClay.template

Link to comment
Share on other sites
13 hours ago, MrFish said:

Hi Gunther

Trying to use the attached template file but it causes MC2019 to crash every time. This is a new template that I created through x+ in MC2019, but is laided out exactly the same as we have been using for the last few versions.

 

default - McClay.template

Your template works fine on my system.

Make sure the "Manufaturer name" of your tools is set. It shouldn't be empty!!!

I need to check this parameter to avoid a crash. It is already on my to do list ;)

 

 

 

Link to comment
Share on other sites
7 hours ago, Günther Massimo - GMCCS said:

Your template works fine on my system.

Make sure the "Manufaturer name" of your tools is set. It shouldn't be empty!!!

I need to check this parameter to avoid a crash. It is already on my to do list ;)

 

 

 

Hi Gunther

Yes filling in the tool manufacturer name worked. Removing this from our selection to be displayed also worked. 

This did used to work fine in all the previous versions before MC2019 without the tool manufacturer being filled in, it would just leave the space blank and not cause a crash.

For us we have a lot of tools in our library where the tool manufacturer was not filled out due to the very limited selection mastercam used to have.

Anyway love the product and look forward to the fixed version when you get around to it. In the mean time I will just run without the tool manufacturer column 

Thanks Mark

Link to comment
Share on other sites

Hi Gunther .

I finally got around to try the Add Fixtures C-hook.  Adding a fixture with this user interface is good , but I'm thinking that , with one little add on , you could make this very simple but  very  effective c-hook be applcable to other  file based geometry .  I would be very interested in using your interface for mold design.  Until now I have used Merge, for this but if you added  the same kind of placement interface as Merge has then  this tool would be even more universal.   

Also , if you could post a link to the video describing this  c-hook again , I would be very obliged.  I tried a search on this site but could not find it....

 

Gracjan

 

 

 

5ad983869519b_postionreselect.thumb.png.ee99f7358b4bd57a3d2109aff7367151.png

Link to comment
Share on other sites
On 24.4.2018 at 11:33 PM, Joe6Pack said:

Is there a way to change the field headers other than to edit the dll?

https://github.com/thadseaver/xplus-rename

or

Use the CSS Styles

/* ------------------------------------------------------- */
/* renaming column names */
/* ------------------------------------------------------- */

/* hide all column names */
.CONTENT_TABLE th
{
	text-indent: -9999px;
	line-height: 0;
}

/* add a new style to display new names */
.CONTENT_TABLE th:after
{
	text-indent: 0;
	line-height: initial;
	display: block;	
}

/* set the new column name for "Group Name" */
.th_27:after {
	content:"Grp Name";
}

/* set the new column name for "Prog Name" */
.th_32:after
{
		content:"NC Name";
}

/* set the new column name for "tl no" */
.th_72:after
{
	content:"T\0023";
}

/* set the new column name for "tl dia" */
.th_62:after
{
	content:"T\00F8";
}

 

  • Thanks 2
  • Like 1
Link to comment
Share on other sites
  • 1 month later...

Gunther, 

I downloaded the zip file to my desktop, my trend micro flags it as ransomware but I ignore the message to block the install and click allow. After I agree to the Terms it tries to install but I get "Mastercam Directory not found\Installation aborted" message. I've used your application since the beginning and it usually just installs without issues. Am I doing something wrong? Please help if you can.

I have a windows 7 pc.

image.png.fb4394d3843e85e9f7e16189d310a759.pngimage.png.c76aed1ee0d10e857cb33807686570e1.png

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

×   Your link has been automatically embedded.   Display as a link instead

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us

×