Recommended Posts

3 hours ago, Günther Massimo - GMCCS said:

X+ is updated for Mastercam 2019.

download

 

 

Awesome!  Now I can officially start using 2019! :lol:

  • Like 1

Share this post


Link to post
Share on other sites

anyone seeing a crash issue launching X+ tool list? 2018 and 2019

mine started today, worked fine last week. nothing was updated

Share this post


Link to post
Share on other sites
Just now, mayday said:

anyone seeing a crash issue launching X+ tool list? 2018 and 2019

mine started today, worked fine last week. nothing was updated

It's working fine on my 2018 box

Share this post


Link to post
Share on other sites

setup sheet etc. work fine, just the tool list is crashing

Share this post


Link to post
Share on other sites
48 minutes ago, mayday said:

setup sheet etc. work fine, just the tool list is crashing

Do you have Tl manufactor selected? If so, change it to Tl Mfg code. It was change in 2018.

  • Like 1

Share this post


Link to post
Share on other sites

i just ran the windows update, working now

 

1.PNG

Share this post


Link to post
Share on other sites
On 3/16/2018 at 7:58 AM, Günther Massimo - GMCCS said:

X+ is updated for Mastercam 2019.

download

 

 

Is it possible to add misc integers or reals to the output of X+ setup sheets?

Share this post


Link to post
Share on other sites
On 3/17/2018 at 1:58 AM, Günther Massimo - GMCCS said:

X+ is updated for Mastercam 2019.

download

 

 

Hi Gunther

Trying to use the attached template file but it causes MC2019 to crash every time. This is a new template that I created through x+ in MC2019, but is laided out exactly the same as we have been using for the last few versions.

 

default - McClay.template

Share this post


Link to post
Share on other sites
13 hours ago, MrFish said:

Hi Gunther

Trying to use the attached template file but it causes MC2019 to crash every time. This is a new template that I created through x+ in MC2019, but is laided out exactly the same as we have been using for the last few versions.

 

default - McClay.template

Your template works fine on my system.

Make sure the "Manufaturer name" of your tools is set. It shouldn't be empty!!!

I need to check this parameter to avoid a crash. It is already on my to do list ;)

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, Günther Massimo - GMCCS said:

Your template works fine on my system.

Make sure the "Manufaturer name" of your tools is set. It shouldn't be empty!!!

I need to check this parameter to avoid a crash. It is already on my to do list ;)

 

 

 

Hi Gunther

Yes filling in the tool manufacturer name worked. Removing this from our selection to be displayed also worked. 

This did used to work fine in all the previous versions before MC2019 without the tool manufacturer being filled in, it would just leave the space blank and not cause a crash.

For us we have a lot of tools in our library where the tool manufacturer was not filled out due to the very limited selection mastercam used to have.

Anyway love the product and look forward to the fixed version when you get around to it. In the mean time I will just run without the tool manufacturer column 

Thanks Mark

Share this post


Link to post
Share on other sites
11 hours ago, Günther Massimo - GMCCS said:

It should work now.

download

Works a treat. Much appreciated Gunther. 

Thanks Mark

Share this post


Link to post
Share on other sites

Hi Gunther .

I finally got around to try the Add Fixtures C-hook.  Adding a fixture with this user interface is good , but I'm thinking that , with one little add on , you could make this very simple but  very  effective c-hook be applcable to other  file based geometry .  I would be very interested in using your interface for mold design.  Until now I have used Merge, for this but if you added  the same kind of placement interface as Merge has then  this tool would be even more universal.   

Also , if you could post a link to the video describing this  c-hook again , I would be very obliged.  I tried a search on this site but could not find it....

 

Gracjan

 

 

 

5ad983869519b_postionreselect.thumb.png.ee99f7358b4bd57a3d2109aff7367151.png

Share this post


Link to post
Share on other sites
On 24.4.2018 at 11:33 PM, Joe6Pack said:

Is there a way to change the field headers other than to edit the dll?

https://github.com/thadseaver/xplus-rename

or

Use the CSS Styles

/* ------------------------------------------------------- */
/* renaming column names */
/* ------------------------------------------------------- */

/* hide all column names */
.CONTENT_TABLE th
{
	text-indent: -9999px;
	line-height: 0;
}

/* add a new style to display new names */
.CONTENT_TABLE th:after
{
	text-indent: 0;
	line-height: initial;
	display: block;	
}

/* set the new column name for "Group Name" */
.th_27:after {
	content:"Grp Name";
}

/* set the new column name for "Prog Name" */
.th_32:after
{
		content:"NC Name";
}

/* set the new column name for "tl no" */
.th_72:after
{
	content:"T\0023";
}

/* set the new column name for "tl dia" */
.th_62:after
{
	content:"T\00F8";
}

 

  • Thanks 2
  • Like 1

Share this post


Link to post
Share on other sites

Gunther, 

I downloaded the zip file to my desktop, my trend micro flags it as ransomware but I ignore the message to block the install and click allow. After I agree to the Terms it tries to install but I get "Mastercam Directory not found\Installation aborted" message. I've used your application since the beginning and it usually just installs without issues. Am I doing something wrong? Please help if you can.

I have a windows 7 pc.

image.png.fb4394d3843e85e9f7e16189d310a759.pngimage.png.c76aed1ee0d10e857cb33807686570e1.png

 

Share this post


Link to post
Share on other sites

Hi Gunther,

For some reason, I cannot extract the Setup X+_2019_en.exe app and run to install.  The fixtures app installs perfectly.

Anybody else having a problem like this?

I am running WIndows 7 pro.

Thank you

 

 

 

Share this post


Link to post
Share on other sites

Finally got around to setting up the Fixtures utility. Excellent little utility. Thanks heaps for producing and sharing this Gunther.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us