Sign in to follow this  
RobP

X7 graphics locked after Win10 update?!?

Recommended Posts

I was wondering if anyone had this issue and found a decent work around or fix.

Windows 10 64-bit fresh install, and fresh install of X7. I can do nothing in the work area. I cannot rotate the view, change view, or draw anything. Once I disable Hardware Acceleration in screen settings, it works, but once I load a file it becomes very slow.

I have the latest drivers etc. Just wondering if someone has been through this, or could offer me insight as to where to look to try and fix this.

I do have 2018 and it works fine.

The backstory on my problem is that everything was working fine until one day it just stopped, possibly after a Win10 update. Possibly after having someone come in to install MCAM2018.

 

Share this post


Link to post
Share on other sites

Does X7 even run on Windows 10??

Share this post


Link to post
Share on other sites

I had the same trouble, my fix was going into the folder that is on the hard drive, finding the Advanced configuration file, opening it and turning off the Graphics Acceleration. 

Share this post


Link to post
Share on other sites
On 4/4/2018 at 2:52 PM, Eoelkins said:

I had the same trouble, my fix was going into the folder that is on the hard drive, finding the Advanced configuration file, opening it and turning off the Graphics Acceleration. 

Sorry, but I'm really lost at where you're trying to send me to find this GFX Acceleration option that can be turned off.

I've tried all the other suggestions.

This is a problem on 2 machines sitting next to each other. Both Nvidia cards, one a 660 and one a 980, both Intel I5 CPUs. This setup has run solid for over 2 years, and didn't go down in flames until around the time 2018 was installed which also coincided with Windows 10 Fall Release Update. Since then, it will load, but I am locked out of the Workspace. I can see a cursor and click on icons, but I just can't do anything or manipulate anything in the workspace.

The most frustrating thing is everything was working fine, and then one day just doesn't. I'm personally blaming the Windows update, but that would mean others should be in the same boat, and so there should be a troubleshooting path that can fix this, but so far I haven't been able to find it.

Share this post


Link to post
Share on other sites

I had the same trouble, my fix was going into the folder that is on the hard drive, finding the Advanced configuration file, opening it and turning off the Graphics Acceleration. 

Share this post


Link to post
Share on other sites

I had to go into the root of the drive that Mastercam was on and open the folder that was accociated with M.C.  I found the file in

C:/Windows/Program Files/Mastercam 

I clicked on the file "McamAdvConfig"... Then windows ask for permission to make a change to your device. Click "Yes". 

Click "Graphics Support" and then hover over the "Enable/Disable" of Hardware Acceleration. I changed the GFX setting in that location and green check. 

In X7 these settings may be in the "System Configuration"

Share this post


Link to post
Share on other sites

One more thing that I may throw out on this issue. You can right click the MC start up icon, select properties, and click the tab compatibility, put a check in the "compatibility mode" box and run as Windows 7.  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us