Sign in to follow this  
DCOPE17

NC output arcs with Z moves instead of line segments

Recommended Posts

I have a simple profile that I want to do a contour ramp instead of depth cuts just to keep the tool engaged, but when I post it, I get a thousand lines to make one revolution around the part. 

Linearize helix is OFF in the operation... when I post helix bore ops, I get arc moves with a Z. 

Entities are arcs and lines only, no NURBS. 

 

What am I missing?

 

Dan

Share this post


Link to post
Share on other sites

Check kin the filter settings. I think there is a box in the lower right corner 

Share this post


Link to post
Share on other sites

you also need to go tot eh ARCS page in your Control Definition and be sure Z axis arcs are enabled

Share this post


Link to post
Share on other sites

On the filter screen, that is a 3D arc entry, I don't think it affect the profile toolpath, just the start. Plus it is greyed out and I cannot use it. 

 

In the Control Def,  all the arcs are enabled. The helix bore works correctly. 

 

In backplot, if going in step by step, each arc and straight line are a single move, so I should get about 10 lines of code each time it completes a lap. 

 

What I have done now is a lead in/ lead out that pretty much just does a circle so the movements are still fluid but would be nice to have it engage the part and keep spirialing down with no short straight lines. ( surface finish is critical here ) 

Share this post


Link to post
Share on other sites

okay, did a bit more testing... I turned off break arcs into quadrants so now I do get complete 90 and 180 degree arc moves. ( I guess I actually did before ) 

 

What I have is the straight lines are broken up into several segments. ( I didn't notice that it did output arce because I had to scrool down so far to get to the first G2. 

 

so corners are good, lines are broken into pieces. this probably won't hurt anything nut if anyone has any ideas to get the lines into a single move, that would really help. 

If I have the depth in the ramp settings at something like .015, I get the code that I want... but when I drop it down to .0015, I get the linear moves split into many moves. I guess specifically this is where the trouble lies. 

 

Thanks for the help

DAn

Share this post


Link to post
Share on other sites
10 hours ago, DCOPE17 said:

okay, did a bit more testing... I turned off break arcs into quadrants so now I do get complete 90 and 180 degree arc moves. ( I guess I actually did before ) 

 

What I have is the straight lines are broken up into several segments. ( I didn't notice that it did output arce because I had to scrool down so far to get to the first G2. 

 

so corners are good, lines are broken into pieces. this probably won't hurt anything nut if anyone has any ideas to get the lines into a single move, that would really help. 

If I have the depth in the ramp settings at something like .015, I get the code that I want... but when I drop it down to .0015, I get the linear moves split into many moves. I guess specifically this is where the trouble lies. 

 

Thanks for the help

DAn

So, if I understand you correctly, when you set your depth per ramp pass, to .015, then you get clean single lines (ramped), that connect the corners. When you drop the depth per pass to .0015, you are getting a bunch of small line segments instead? 

If that is the case, I think you need to adjust the System Tolerance values.

I forget which one specifically, but I think there is a tolerance for "minimum depth for helix" or something like that. I think one of these tolerances needs to be adjusted.

Also, what are your actual "Filter" settings? The Filter includes two separate filter components. One filters for Lines, the other attempts to create Arcs. You can play with the 'tighten arc' or 'tighten line' options. If you use those, you are saying "only use this amount of the Filter tolerance value".

For example, say your total tolerance is .001. There are many ways to divide up that tolerance.

For finishing, I'd recommend a Cut Tolerance of .0002, with a Filter Tolerance of .0008. That should be 20% for Cut Tol and 80% for Filter Tol.

 

Share this post


Link to post
Share on other sites

I went into the control def tolerances and changed "Chordial deviation ( used in post )" from .0005 to 1.0 and that is the only setting that had any affect on the straight line moves. The straight lines are still broken up, but there are a lot fewer lines. 

I played with smoothing settings with no affect at all. 

 

Thanks for the help, I'll try the segmented straight lines with some comp to have a look before cutting to size. It might be a non issue???

Dan

Share this post


Link to post
Share on other sites

After roughing the part, don't change that Chordial deviation setting, it loosens your tolerances on everything. Definitely looked weird but all is good for finishing. 

Share this post


Link to post
Share on other sites

Yeah, definitely do not mess with raising the Chordal Tolerance.

I would posit that the Fillter has a hard time with Ramp moves. I'd suggest using the Filter as you did before, and let the path output a bunch of small line segments.

Then, after you have tweaked all the other parameters the way you want and have a clean Toolpath, you can run the "FilterNCI.dll" Chook, to further filter the tool motion. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us