Sign in to follow this  
MES

Mill Face Problem

Recommended Posts

Good morning. My MC 2019 was working fine but yesterday in the afternoon the FACE (milling) do not work anymore. Do not Windows 10 update or driver update.

I move the key to another PC and the same problem. We use the other key in the different PC and the same.

Not Backplot and when you try generate the g code MC show this message.

image.png.7d7fbab1fd0d663bbe452964b6470f0d.png

 

The FACE in the old MC files are OK.

 The file is attached.

Thanks in advance.

 

MES

Face Test Original.mcam

Share this post


Link to post
Share on other sites

I tried it with my machine and post and I did not get any errors. Regens fine as well.

Share this post


Link to post
Share on other sites

This is a known error and has been addressed in 2020. Have you tried recreating the toolpath? That seems to be the only way to fix it.

Share this post


Link to post
Share on other sites

Rekd, thanks.

5th Axis CGi, thanks, I never see this error before, now the two MC seat here are unavailable to generate FACE.

I don't  know how to fix it. I am thinking reinstall MC2019,  but after your answer  i don't know if a new fresh MC fix it.

Thanks

MES

Share this post


Link to post
Share on other sites
8 hours ago, MES said:

Rekd, thanks.

5th Axis CGi, thanks, I never see this error before, now the two MC seat here are unavailable to generate FACE.

I don't  know how to fix it. I am thinking reinstall MC2019,  but after your answer  i don't know if a new fresh MC fix it.

Thanks

MES

I was wrong and the correct answer was given.

Edited by 5th Axis CGI
I didn't have the best answer.

Share this post


Link to post
Share on other sites

The issue here is depth cuts are turned on, with depth set to zero. Turn depth cuts off and you should see it generate/backplot/post OK. This has been addressed for 2020.


Edit: They aren't set to zero in your path, but the gist is that yes, depth cuts are causing the issue here, and you're not doing anything wrong. Setting Top of Stock to something other than absolute/incremental zero will also allow the toolpath to generate correctly WITH depth cuts.

  • Like 1

Share this post


Link to post
Share on other sites

ajmer

.....turn off depth cuts and it works on my computer....

It is the problem, I did not know I am using 2019 for one year and never see before.

Thanks  for your s answer.

MES

Share this post


Link to post
Share on other sites

turning off depth cuts works for me most of the time as well, as long as the tool isnt close to the same size as the geometry. I am glad there will be a 2020 fix.

Share this post


Link to post
Share on other sites

I went back to the problem I reported and turned off Depth of cuts that had Zero and I was able to back plot and post code. I never remember turning that on, but the file is many version old and been shared for years so no telling when or if that happened. Glad we got an answer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us