Bama

turning G64 on at the end of a toolpath that is using G61.1

Recommended Posts

Im trying to figure out how to add G64 at the end of the tool after my G05 P0 turning off high speed to turn my High Speed Smoothing off. I see it in my post but its not turning the G64 on

not sure why its not working I have a postability post that says the same thing and it works so im not sure just trying to add it to my other post for a different machineCapture.JPG.975c4e9dfa5afe0b047095e6e9964ac9.JPG

 

 

Capture.JPG

  • Like 1

Share this post


Link to post
Share on other sites

I think there could be a few different reasons why this isn't working. If the Postability post is using a string select table to set the high speed option on or off but this new post is not, then simply copying and pasting those postblocks in without the string select table won't work. If you say that it's at least turning on the high speed options in the new post then there must be a string select table it's using but potentially a correct flag isn't being set.

Can you show the phsm_on postblock as well?

Share this post


Link to post
Share on other sites

Try this modification:

      if hsm3_flg,
        [
        pbld, pn, *sghsm3, "P0", pe, pms
        pbld, pn, "G64", pe, pms
        hsm3_flg = 0
        ]

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Bama said:

1470156615_Capture3.thumb.JPG.4f5409d71c6d8674b619ae75dc6efb38.JPG

What Colin mentioned should work, but it also looks like the hsm1_flg is not being set to 1 when G61.1 is turned on. This is basically telling the post later on that G61.1 is not on so it has no reason to turn it off with G64 in the phsm1_off postblock. In the pshmb_on postblock change the last line for Option 1 from "hsm1_flg = 0" to "hsm1_flg = 1" and try that.

Just as a side note for future reference, instead of posting images of code you can copy and paste it into the code window (the <> icon above the normal text window) like Colin did in his reply. This keeps all the formatting the same and allows other users to copy and edit it to make it clear what should be changed.

  • Like 2

Share this post


Link to post
Share on other sites

ok thank you and Colin that worked thank both of yall for the help much appreciated. thanks for the tip on the copy and paste as well I was looking for that lastnight when I was writing the post

  • Like 2

Share this post


Link to post
Share on other sites

Frank was correct. You shouldn't need to add the "string literal", since there is already a bit of code to turn it off. Frank is right that the flag was not set.

So fix it following Frank's advice...

  • Like 1

Share this post


Link to post
Share on other sites

Ok thanks I did that on my other post that wouldn't work as well for the older machines post and his idea work. Ive noticed that it says you used to do online post classes where can I find them to watch ?

Share this post


Link to post
Share on other sites
49 minutes ago, Colin Gilchrist said:

Frank was correct. You shouldn't need to add the "string literal", since there is already a bit of code to turn it off. Frank is right that the flag was not set.

So fix it following Frank's advice...

I don't get to mess around with serious post stuff too often so it's always nice to get confirmation from the Post Man himself, lol. Thanks, Colin.

  • Like 2

Share this post


Link to post
Share on other sites

Hey where do you find your hasp as I am on a network and not sure where to find the #. just want to make my account legit do not want people thinking im pirating my MasterCam. This is how I feed the family. So the better I am the better we eat lol.

Share this post


Link to post
Share on other sites

whats the number look like all I see is the ip address

Share this post


Link to post
Share on other sites

Wonder with it being on a server if its blocked out cause I do not see that under mine anywhere

Share this post


Link to post
Share on other sites

I think it also appears at the top of the mastercam launcher

Share this post


Link to post
Share on other sites

man I appreciate the help I think ill just ask our IT guy to give it to me im not seeing anything lol

  • Haha 1

Share this post


Link to post
Share on other sites
1 minute ago, jeff.D said:

Launch Mastercam and press Alt+V.

Your a pro! :D

  • Haha 1

Share this post


Link to post
Share on other sites

actually I found it. I created a z2g file and got it from there

 

Share this post


Link to post
Share on other sites

that way works as well thanks bud

Share this post


Link to post
Share on other sites

Thanks for the help guys

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us