Cavi Mike

Verified Members
  • Content count

    28
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Cavi Mike

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Cavi Mike

    Why does mastercam work in reverse?

    Ahh, the good ole' MC community - it's never the software, it's always the user. Right. Just stacks and stacks of excuses from you people why your software is sub-par.
  2. Instead of only cutting what I've selected for it to cut, it cuts everything except for what I've told it not to cut. This is very time consuming trying to draw all sorts of avoidance boundaries. I really don't understand why it's like this. I'm only on 2018 and I don't see this shop updating in the foreseeable future - so maybe this is something that has been fixed in subsequent releases? But if it isn't, it really should be.
  3. Cavi Mike

    change 4th axis rotary output

    Never actually thought to check the location of Selway until now, turns out we're (sort of) neighbors. I'm in Vancouver. Small world.
  4. Cavi Mike

    change 4th axis rotary output

    I forgot to reply to this yesterday, I changed a value in pcoutrev from 360 to 180 and got what I was looking for. I actually then changed it to 225 so I could go past 180 if need be. If this causes me problems I'll give yours a shot. while cabs > 225 & absinc$ <> 1, cabs = cabs - 360
  5. Cavi Mike

    change 4th axis rotary output

    And yes, I've also messed around with all of the obvious things. I too believe this is something with the post, not the control and/or machine definitions.
  6. Cavi Mike

    change 4th axis rotary output

    Did anyone find a solution to this? I've been having this problem as well but wasn't a big deal until now - I have a part that will crash into the machine if the table swings all the way around the back. I need a solution to this.
  7. Cavi Mike

    Showing hidden objects?

    Out of nowhere, somehow I have a random level with 82 entities in it. This has happened before but with only 1 entity so I just ignored it. But this is crazy. I haven't imported anything, it was just all of a sudden here. I've alt+F1, ctrl+A then del - nothing changes. Whatever is here is invisible. Annnd as I was typing this, the computer froze for a few seconds and MC just crashed in the background. Just reopened it, that level is still there with those 82 invisible entities. The hide/unhide doesn't show anything, says nothing is here.
  8. I'll examine that a bit more when I have time but I changed this, [if nextdc$ <> 7, *speed, *spindle] to this. [if nextdc$ < 7 | nextdc$ > 8, *speed, *spindle] It did what I expected of it.
  9. Just realized it has nothing to do with the canned cycle and is part of the tool change.
  10. Ahh, gotcha. And I see the number of options in the list must match that last line. I appreciate the help and the guidance and I do take precautions, chief among which is actually understanding what I'm doing before I mess with it. Unfortunately, there's only so far you can go without having a book full of codes in front of you. Case in point; I never would have found out that "sgc*" is the code for the custom cycles if I didn't see you post it, because obviously that wasn't in my list already. One last question, perhaps? Would you know how to get rid of the spindle speed command like how it's MIA for the "rigid tapping" cycle? I'm using this as a broaching cycle and would rather it not be there at all.
  11. Also, I'm assuming you meant this table? I tried adding to it, but nothing I tried worked. usecandrill$ : yes$ #CD_VAR Use canned cycle for Drill usecanpeck$ : yes$ #CD_VAR Use canned cycle for Peck usecanchip$ : yes$ #CD_VAR Use canned cycle for Chip Break usecantap$ : yes$ #CD_VAR Use canned cycle for Tap usecanbore1$ : yes$ #CD_VAR Use canned cycle for Bore1 usecanbore2$ : yes$ #CD_VAR Use canned cycle for Bore2 usecanmisc1$ : yes$ #CD_VAR Use canned cycle for Misc1 usecanmisc2$ : yes$ #CD_VAR Use canned cycle for Peck Tapping
  12. So I suppose I could just put "G81" there instead?
  13. 19 Dec 2019 08:08:45 AM - Report created. 19 Dec 2019 08:08:45 AM - Initialize posting log file 19 Dec 2019 08:08:45 AM - Using MP run version 20.00 and post components version 20.00 19 Dec 2019 08:08:45 AM - Initiate opening the post processor file(s). 19 Dec 2019 08:08:45 AM - C:\Users\Public\Documents\shared Mcam2018\mill\Posts\Mori MH-40 4axis Post.PST 19 Dec 2019 08:08:45 AM - The post processor file has been successfully opened. 19 Dec 2019 08:08:45 AM - Initialization of pre-defined post variables, strings, postblocks was successful. 19 Dec 2019 08:08:45 AM - Search for defined post variables, strings, postblocks was successful. 19 Dec 2019 08:08:45 AM - RUN TIME -PST(1390)- The value of the string select selection variable is out of range:16 19 Dec 2019 08:08:45 AM - Successful completion of posting process!
  14. No idea what I'm missing here. "RUN TIME -PST(1392)- The value of the string select selection variable is out of range:16" I've greyed out every option in the menu but I'm still getting it. It's referencing this line of code. pdrlcst8 #Broach cycle pdrlcommonb sopen_prn, "SPINDLE ORIENT", sclose_prn, "M19", e$ pcan1, pbld, n$, *sgdrlref, *sgdrill, pxout, pyout, pfzout, pcout, <----this line prdrlout, shftdrl$, *feed, strcantext, e$ pcom_movea
  15. No, it's still there, my mistake.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us