Sign in to follow this  
Followers 0
Kdiver

Mastercam X /Windows 7 64 bit .. Hasp not found

9 posts in this topic

I was running both Mastercam 9.1 Design and Mastercam X Design on my computer running Windows XP pro 64 bit.

 

I upgraded to Windows 7 Home Premium and now can't get either to run .. Both give me a hasp not found error.

I have Windows 7 starter running on my netbook and it is running Mastercam 9.1 just fine.

I installed Mastercam X and it would not run

I installed service pack 1

I installed service pack 1 update 1

I installed service pack 1 update 3

I installed the latest drivers from Alladin for the Hasp

 

I'm concentrating on getting Mastercam X up and running.

Share this post


Link to post
Share on other sites

Windows start button/all programs/mastercam x folder/click on the utility "Hasp X". At the top of the popup window it show a version number. If it is V4.0 it is too old. Go to the mastercam website and download the V5.5 HaspX.exe file. Run it and see if you start and end dates are good. You might have to use it to update your codes.

Share this post


Link to post
Share on other sites

Windows start button/all programs/mastercam x folder/click on the utility "Hasp X". At the top of the popup window it show a version number. If it is V4.0 it is too old. Go to the mastercam website and download the V5.5 HaspX.exe file. Run it and see if you start and end dates are good. You might have to use it to update your codes.

 

 

I found the file under Misc. in the downloads area .. It shows Mastercam X and the dates show Unlimited

Share this post


Link to post
Share on other sites

I had the same problem, the driver fixed it. I had a similar problem and get this - changing the hasp slots on the laptop got it to start working again. Some laptop USB slots seem to be iffy.. ie: can't charge my blackberry either

Share this post


Link to post
Share on other sites

Nevermind, I re-read the original post and see that you are trying to get v9 and X to run on Windows 7 instead of XP. X4 was the first version supported by Windows 7. V9 and X are not going to run on Windows 7 and is not supported by mastercam.

Share this post


Link to post
Share on other sites
I was running both Mastercam 9.1 Design and Mastercam X Design on my computer running Windows XP pro 64 bit.

 

Really, can you tell us how?

 

Are you running a Nethasp or is this another Bigfoot sighting?

Share this post


Link to post
Share on other sites

My provider sent me a MR update for Mastercam X and it's now up and running on my Windows 7 64bit machine.

 

I'm guessing V9.1 runs on my Netbook running Windows 7 starter because it's 32 bit I don't know.

 

I never had a problem running V9.1 or Mastercam X on my XP 64bit machine . I have a regular hasp not a net hasp.

 

In reference to the bigfoot reference .. I don't have time to waste lying to people while trying to get help.

Share this post


Link to post
Share on other sites
I never had a problem running V9.1 or Mastercam X on my XP 64bit machine .

 

Can you tell us how? People have stated this before but no one has ever been able to say what they've done to get it running.

 

Thus my bigfoot comment, claimed but never seen ;)

 

It will run with a Nethasp but the Hasp driver for the USB doesn't support it, so it shouldn't run at all with a USB/Parallel Hasp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us