BBaker3

Tool Manager crashes in 2018

Recommended Posts

New Installation, but had been running 2018 on a different pc.

First time to access Tool Manager.

I can load a library, but double clicking on cutting tools to bring up a list in the center window, crashes the application.

Tried two different libraries, same result.

Task Manager reports ToolManager.shell is "not responding".

Barry in St Louis

2Capture.JPG

1Capture.JPG

Share this post


Link to post
Share on other sites

I have the exact same issue.  Anyone know how to fix it?

Share this post


Link to post
Share on other sites

I have seen this issue occur on laptops with integrated graphics. The Tool Manager, for whatever reason, tries to use the Intel integrated graphics first, and when it needs to draw something on the screen, like when you double click on Cutting Tools or Holders after opening a library, it instantly locks up. I went up and down driver revisions for the Intel integrated graphics on my laptop and couldn't solve the issue that way.

The solution is to force the use of your dedicated graphics card for the Tool Manager application. This applies to desktops with integrated graphics as well- This is the process for NVIDIA cards:

1. Right click on the desktop and choose Nvidia Control Panel.

2. Go to Manage 3D Settings on the lefthand side.

3. Choose the Program Settings tab on the right.

4. Select Add under "Select a program to customize", and navigate to the location of your tool manager. By default for 2018, that is C:\Program Files\Mcam2018\Extensions\ToolManager.exe

5. Under "Select the preferred graphics processor for this program:", select High-Performance NVIDIA processor to force Tool Manager to open with the NVIDIA card and skip the Intel integrated graphics.

6. Hit apply in the bottom right corner. Repeat these steps for any other installed versions of Mastercam to ensure each tool manager version works with the dedicated card. You should now immediately be able to open up the tool manager and view libraries without crashes.

 

See the attached image for reference

Graphics Settings.PNG

  • Thanks 1
  • Like 4

Share this post


Link to post
Share on other sites

That's the ticket!!!  Works great!

Thank you

Share this post


Link to post
Share on other sites
On 5/17/2018 at 3:31 AM, savagkd said:

I have the exact same issue.  Anyone know how to fix it?

 

On 5/18/2018 at 11:28 PM, Chally72 said:

I have seen this issue occur on laptops with integrated graphics. The Tool Manager, for whatever reason, tries to use the Intel integrated graphics first, and when it needs to draw something on the screen, like when you double click on Cutting Tools or Holders after opening a library, it instantly locks up. I went up and down driver revisions for the Intel integrated graphics on my laptop and couldn't solve the issue that way.

The solution is to force the use of your dedicated graphics card for the Tool Manager application. This applies to desktops with integrated graphics as well- This is the process for NVIDIA cards:

1. Right click on the desktop and choose Nvidia Control Panel.

2. Go to Manage 3D Settings on the lefthand side.

3. Choose the Program Settings tab on the right.

4. Select Add under "Select a program to customize", and navigate to the location of your tool manager. By default for 2018, that is C:\Program Files\Mcam2018\Extensions\ToolManager.exe

5. Under "Select the preferred graphics processor for this program:", select High-Performance NVIDIA processor to force Tool Manager to open with the NVIDIA card and skip the Intel integrated graphics.

6. Hit apply in the bottom right corner. Repeat these steps for any other installed versions of Mastercam to ensure each tool manager version works with the dedicated card. You should now immediately be able to open up the tool manager and view libraries without crashes.

 

See the attached image for reference

Graphics Settings.PNG

 hi thanks for tips ,

i am having same issue .

BTW, do you know how to change   3d graphic setting  in INTEL ? i dont have nvidia graphic card...

 

cheers

Share this post


Link to post
Share on other sites

Hi Juyong,

If you only have Intel integrated graphics, you could try different driver versions and see if you find one that works. Mastercam is not supported on integrated graphics cards, however.

Share this post


Link to post
Share on other sites
20 hours ago, Chally72 said:

Hi Juyong,

Mastercam is not supported on integrated graphics cards, however.

Looks like M/C 2020 will not even start if you have integrated graphics, it does a system check first. In older versions you could disable hardware acceleration to at least run the software but there is no settings for this any more.

Share this post


Link to post
Share on other sites

Hi Radical1,

The option to turn off the Hardware acceleration is now located in the Mastercam Launcher (found in the installation folder in the Mastercam folder from the Windows Start menu). Here is a screenshot:

image.thumb.png.970807935561b9ea1a8babd6f1c40d86.png

Hope this helps.

Patrik

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us