Luke.Hicks430

Accuracy of simulation in Verify for MC 2019

Recommended Posts

Hello Friends,

I recently got a new job. My old workplace had MC X6 and my new workplace has 2019.

I am having trouble increasing the accuracy of the visualization in the "Verify" window. In X6, I could just go to the options and specify the tolerance I wanted. I have not been able to find a way to do that in 2019. I have noticed in 2019 that there is a "Performance-------Precision" slider which I have all the way to precision.

I am trying to verify a part's surface finish toolpaths and realized that the window I was looking at was very pixelated. I have attached a picture of the simulation of a simple arc cut that turned out very pixelated.

How do I increase the precision beyond what the slider can give me? Is 2019's verify less precise than X6?

Many thanks!

Verify screenshot.png

Share this post


Link to post
Share on other sites

Go to the Verify tab and select accurate zoom option.  This will cut away the other section of the verified part and make the area you a looking at more precise.  Once your done looking if you zoom out you will notice the rest of the stock model isnt there anymore.  So in that case you will need to click the reset zoom button.

  • Thanks 1

Share this post


Link to post
Share on other sites

Just remember X6 was still using Light Waves for verification.

Verification is now by Moduleworks so it is bound to be different. Try File/options for tolerance settings.

I think the "pixilating" is actually incomplete processing of the triangles (or corrupt triangles) from which the .stl is made.

If you zoom on a ragged edge and click you will notice the enhancing model and/or enhancing view bars at the bottom start to regenerate . If you want a fully regenned and "clean" display it can take a while for the system to repair everything on a complex surface, there could be 10s even 100s of thousands of triangles to regenerate.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Chris,

The accurate zoom button fixed it. It is odd that the simulator does not dynamically regenerate when zooming. Thank you for the tip!

Nickbe, thank you for your input as well!

  • Like 1

Share this post


Link to post
Share on other sites
57 minutes ago, Luke.Hicks430 said:

Chris,

The accurate zoom button fixed it. It is odd that the simulator does not dynamically regenerate when zooming. Thank you for the tip!

Nickbe, thank you for your input as well!

Was there not an option for that in the settings? In X7 by memory, the accurate zoom was on automatically when zooming and would hog resource? So you could de-activate it.

Tell me I'm not dreaming...

Share this post


Link to post
Share on other sites
Quote

Was there not an option for that in the settings? 

If there is, I didn't see it.

Share this post


Link to post
Share on other sites

If you want verify to become more accurate automatically as you zoom in click the file tab inside verify then click options.  Once there select the check box for adaptive quality.  You will have to restart the mastercam simulator for the change to take affect. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us