Sign in to follow this  
c++

INVALID FEEDRATE : POSTS F0.

Recommended Posts

Hi, some of my operations are displaying invalid feed rate and outputting f0. when I post, however thei IS a feed rate set for all tools and ops.

Share this post


Link to post
Share on other sites
5 minutes ago, Leon82 said:

Is it set in the tool or just the parameter page

It is set in both.

Share this post


Link to post
Share on other sites

are you getting the F0. on a line by itself?

I've seen that while using contour

add ` to the feed variable so if it's the only thing to be output on a line, it will not post

 

Share this post


Link to post
Share on other sites
8 minutes ago, JParis said:

are you getting the F0. on a line by itself?

I've seen that while using contour

add ` to the feed variable so if it's the only thing to be output on a line, it will not post

 

Nah it was in the line with the interpolation commands and the coordiantes. I scrubbed my configuration and machine and control def and replaced it with the backup..it is still giving me problems.

Share this post


Link to post
Share on other sites

I've seen this happen when using Dynamic Milling with Entry Motion/Entry Feeds and speeds checked. It used to post the tools feed if the value was zero and then at some point it started posting F0 and S0.

I don't know if that's still the case or if it's the issue you're having. 

  • Like 1

Share this post


Link to post
Share on other sites
22 minutes ago, Neurosis said:

I've seen this happen when using Dynamic Milling with Entry Motion/Entry Feeds and speeds checked. It used to post the tools feed if the value was zero and then at some point it started posting F0 and S0.

I don't know if that's still the case or if it's the issue you're having. 

It was a pocket op, which contains overrides on the entry and lead in etc. , however the program was pre-existing and didn't show the error outside of the nesting operation.  

Share this post


Link to post
Share on other sites

Thinking about doing a reinstall, .. 😢 everything was fine before windows 10!!!!

Share this post


Link to post
Share on other sites

check all the Lead in / lead out pages, there is feed rate overrides on most of them and make sure ones not turned on with 0 entered.  also check every Dynamic toolpaths Cut paramaters for the Back Feed Rate setting and make sure its not set to 0. Most likely its actually something set to 0 in a toolpath, seen many times on the leadin/out page and/or people forgetting to place the feedrate on cut paramaters back feed setting in dynamic toolpaths.

  • Like 2

Share this post


Link to post
Share on other sites
12 hours ago, JoshC said:

check all the Lead in / lead out pages, there is feed rate overrides on most of them and make sure ones not turned on with 0 entered.  also check every Dynamic toolpaths Cut paramaters for the Back Feed Rate setting and make sure its not set to 0. Most likely its actually something set to 0 in a toolpath, seen many times on the leadin/out page and/or people forgetting to place the feedrate on cut paramaters back feed setting in dynamic toolpaths.

I can't find the problem for now my fix is swap out all the "old style pockets" with "area mill"

Share this post


Link to post
Share on other sites

How old is this post.

I have had this issue with posts that predate the dynamic toolpaths.

I think it is because they do not have the parameter that supports the backfeed variable

Share this post


Link to post
Share on other sites

Its probably 3 or 4 years old.. we got it from DMS.The issue however is with the old style pocket toolpath

Share this post


Link to post
Share on other sites
49 minutes ago, Leon82 said:

There is an override feed in the finish tab also

and if memory serves, it is defaulted to 0 in a clean MC2020 install.

I know I have had this problem, but do not recall how I fixed it

Share this post


Link to post
Share on other sites
11 minutes ago, gcode said:

and if memory serves, it is defaulted to 0 in a clean MC2020 install.

I know I have had this problem, but do not recall how I fixed it

G,

It is a clean install of 2018, for the moment I am converting all my 2D pockets for the Hardmill pockets/

Share this post


Link to post
Share on other sites

Once in a while I will accidentally click one of these buttons and will get the F0 error.

 

Capture.PNG

Share this post


Link to post
Share on other sites

Must be a post issue

This is an open pocket using your operation  with no edits posted with an old mpmaster based VMC post

I tried it with the default mill post that ships with MC2020 and got similar results,

no F0's anywhere

 

G00 G17 G20 G40 G80 G90
T3
M06
N3 (DEFINE TOOL NAMES)
G00 G17 G90 G54 X.4148 Y-1.8945 S18000 M03
G43 H3 Z.25
G01 Z-.465 F50.
Y-1.832 F300.
Y-.8314
X.6535
Y-1.832
Y-1.8945
X.2898
Y-1.832
Y-.7064
X.7785
Y-1.832
Y-1.8945
X.1648
Y-1.832
Y-.5814
X.9035
Y-1.832
Y-1.8945
X.0398
Y-1.832
Y-.4564
X1.0285
Y-1.832
Y-1.8945
X-.0852
Y-1.832
Y-.3314
X1.1535
Y-1.832
Y-1.8945
X-.2102
Y-1.832
Y-.2064
X1.2785
Y-1.832
Y-1.8945
X-.3352
Y-1.832
Y-.0814
X1.4035
Y-1.832
Y-1.8945
X-.4602
Y-1.832
Y.0436
X1.5285
Y-1.832
Y-1.8945
X-.5852
Y-1.832
Y.1686
X1.6535
Y-1.832
Y-1.8945
X-.7102
Y-1.832
Y.2936
X1.7785
Y-1.832
Y-1.8945
X-.8352
Y-1.832
Y.4186
X1.9035
Y-1.832
Y-1.8945
X-.9602
Y-1.832
Y.5436
X2.0285
Y-1.832
Y-1.8945
X-1.0852
Y-1.832
Y.6686
X2.1535
Y-1.832
Y-1.8945
X-1.2102
Y-1.832
Y.7936
X2.2785
Y-1.832
Y-1.8945
X-1.3352
Y-1.832
Y.9186
X2.4035
Y-1.832
Y-1.8945
X-1.4602
Y-1.832
Y1.0436
X2.5285
Y-1.832
Y-1.8945
X-1.5852
Y-1.832
Y1.1686
X2.6535
Y-1.832
Y-1.8945
X-1.7102
Y-1.832
Y1.2936
X2.7785
Y-1.832
Y-1.8945
X-1.8352
Y-1.832
Y1.4186
X2.9035
Y-1.832
Y-1.8945
G00 Z.25
M05
G91 G28 Z0.
G28 Y0.
G90
M30
%

Share this post


Link to post
Share on other sites
2 minutes ago, gcode said:

Must be a post issue

This is an open pocket using your operation  with no edits posted with an old mpmaster based VMC post

 

G00 G17 G20 G40 G80 G90
T3
M06
N3 (DEFINE TOOL NAMES)
G00 G17 G90 G54 X.4148 Y-1.8945 S18000 M03
G43 H3 Z.25
G01 Z-.465 F50.
Y-1.832 F300.
Y-.8314
X.6535
Y-1.832
Y-1.8945
X.2898
Y-1.832
Y-.7064
X.7785
Y-1.832
Y-1.8945
X.1648
Y-1.832
Y-.5814
X.9035
Y-1.832
Y-1.8945
X.0398
Y-1.832
Y-.4564
X1.0285
Y-1.832
Y-1.8945
X-.0852
Y-1.832
Y-.3314
X1.1535
Y-1.832
Y-1.8945
X-.2102
Y-1.832
Y-.2064
X1.2785
Y-1.832
Y-1.8945
X-.3352
Y-1.832
Y-.0814
X1.4035
Y-1.832
Y-1.8945
X-.4602
Y-1.832
Y.0436
X1.5285
Y-1.832
Y-1.8945
X-.5852
Y-1.832
Y.1686
X1.6535
Y-1.832
Y-1.8945
X-.7102
Y-1.832
Y.2936
X1.7785
Y-1.832
Y-1.8945
X-.8352
Y-1.832
Y.4186
X1.9035
Y-1.832
Y-1.8945
X-.9602
Y-1.832
Y.5436
X2.0285
Y-1.832
Y-1.8945
X-1.0852
Y-1.832
Y.6686
X2.1535
Y-1.832
Y-1.8945
X-1.2102
Y-1.832
Y.7936
X2.2785
Y-1.832
Y-1.8945
X-1.3352
Y-1.832
Y.9186
X2.4035
Y-1.832
Y-1.8945
X-1.4602
Y-1.832
Y1.0436
X2.5285
Y-1.832
Y-1.8945
X-1.5852
Y-1.832
Y1.1686
X2.6535
Y-1.832
Y-1.8945
X-1.7102
Y-1.832
Y1.2936
X2.7785
Y-1.832
Y-1.8945
X-1.8352
Y-1.832
Y1.4186
X2.9035
Y-1.832
Y-1.8945
G00 Z.25
M05
G91 G28 Z0.
G28 Y0.
G90
M30
%

Thank you for taking the time to do this, I appear to be the only user affected, and only for one operation, I requested a reinstall for my mastercam from local IT, I guess I will be contacting my reseller because I'm in the juice already and now I have to replace ALL my pocket operations with Area mill or dynamic. I was using FBM to do it today lol. That op is bad to the bone.

Share this post


Link to post
Share on other sites

try the "Reload parameters from default file" button in the upper right corner

of the pocket page

 

parameters.jpg

Share this post


Link to post
Share on other sites
Just now, gcode said:

try the "Reload parameters from default file" button in the upper right corner

of the pocket page

 

parameters.jpg

I did try that G, It did not have any effect.. 

Share this post


Link to post
Share on other sites

Does that button pull params from the mill_inch_default library?

Share this post


Link to post
Share on other sites

Try unchecking any keep told down settings.

 

I've seen it post sometimes  just a feed rate on a line, normally the plunge rate

Share this post


Link to post
Share on other sites
11 minutes ago, Leon82 said:

Try unchecking any keep told down settings.

 

I've seen it post sometimes  just a feed rate on a line, normally the plunge rate

I will try, thank you

Share this post


Link to post
Share on other sites

The problem has vanished..for now. 😕 Maybe its time for me to start learning post language.. for the next time a post problem rears its ugly head!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

Join us!

eMastercam - your online source for all things Mastercam.

Together, we are the strongest Mastercam community on the web with over 56,000 members, and our online store offers a wide selection of training materials for all applications and skill levels.

Follow us